summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-12 12:14:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-12 12:14:42 +0100
commit3a0e100e02e1c6c2818268f57eae51095cee35af (patch)
treefdc72a395f9087c6e6dfa08b8a1791f65c5af170 /dev-python/jupyterlab
parentb71bf04bdb3f690dbd36fcda860a5a68c1988f6e (diff)
gentoo auto-resync : 12:10:2023 - 12:14:42
Diffstat (limited to 'dev-python/jupyterlab')
-rw-r--r--dev-python/jupyterlab/Manifest2
-rw-r--r--dev-python/jupyterlab/jupyterlab-4.0.7.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/jupyterlab/Manifest b/dev-python/jupyterlab/Manifest
index ef62910b9e09..2a4047fe25a1 100644
--- a/dev-python/jupyterlab/Manifest
+++ b/dev-python/jupyterlab/Manifest
@@ -1,5 +1,7 @@
DIST jupyterlab-3.6.3.tar.gz 16847186 BLAKE2B 6916722469ab100a1a240b8a565c9800f35535b2a9b2c39a6bfd275b078d88df9faa1f12d4ce3819155af7b0ed22282836f9b233534bd3e63d8a330d1cd7cd21 SHA512 3d6b4781f9fab02504b2c0223a4d060d80c3442fa6ac53ae326296d69942d68f8545450f671f6ba65c7c4e218aad62ef4f4ceb658899c21aaff3640c3055d364
DIST jupyterlab-4.0.6.tar.gz 18236816 BLAKE2B e39e7cb6fbdecfee0b5e592091f989fe94907369d057457130f8bc2f391ca4c83cc09542bc9da766413821eb4c4e9eaaca3adfeccf26b0b2f61ab5e65dac9e45 SHA512 fc4acde65f2bb24adbf95e5cde17e0225390a0c8aca10e04b7c9cf5b2bcebe529608b53ce259f081508b86216b94c71fb260c857b9fe3a2bef16cb4e7af3dcda
+DIST jupyterlab-4.0.7.tar.gz 18316994 BLAKE2B 9965a2bcb0b926af17626e9aef7b37e62144685e4e6cb17b029f3b760d4d4ba583c772683078c3f7cf7fbb09d31e5214193757116873e4457596d7522ddbbf04 SHA512 2f65f8aba9db17574d5caa030437c57ca98808561645f0b30b9fd4fe2cc49f6234776a36db474051cdfeebf1d9e7f3b874189110c955edecb89506580d8917e3
EBUILD jupyterlab-3.6.3.ebuild 2744 BLAKE2B 9cfdab0afb8feff32c1eb0d4f1e641860ff59e72080448805cfc11cfe3a565a7c8fc18b4013f5b78ff83304b21df03ad939d81eac8d9afbbf2bd59ab75f778b2 SHA512 a5ff778dee692241083a51d970ce5025db0976b6abc4c14e15fe39b48427a5a27aee5f91bc6989b3a109ae11590d89e66f15b3dd573cc79caf90118d022ec71c
EBUILD jupyterlab-4.0.6.ebuild 2606 BLAKE2B a156e871e9cbc14f5691a0b5ed35d99a42d24162976ed28204680e770a703a19500e81b23fc467086959079ee6ea85de90da55fafd23bfd3a4d5469f0b6ef86a SHA512 f50455260ab20186e8177a8c8025f824b8bddf68a16fda45385f2cc67106eecffe9dbcbbeeecbf43d70931a18b04d4ef46a723f7d8d8a0c3869a4c3c415f7ae5
+EBUILD jupyterlab-4.0.7.ebuild 2609 BLAKE2B a982cb28bc732374978536544bbf96d7dffe77c6bde34de40c4a78ab95720a83414e6f6b8443ddcd0151801709b5bacff8f32c68a4a4ef5c9ad66fb5ca93de76 SHA512 f66532ec44d14062b56911de35b3ca168f88debd3c0ed424d955a81052b05a676aabb626786ded8667427d307863766d4fb912e2db7d858f59bd8dc69cef8433
MISC metadata.xml 412 BLAKE2B f0b40e19f8ba9dc116f0e4a882cabab6376f22d1eaeb3eac58ecff465ee2aff3564ddbf55e4ffb8971807a39945109a164037a954419671a274d3ac558b102ea SHA512 b6149a03585ca04bc3bf6f3ea6055e8e1fcb620a771359d150df7c22ee16bf09f57c8037df2161021fac0c194be0ac5ec79a31f0511d785e0c5b1ca96d817e42
diff --git a/dev-python/jupyterlab/jupyterlab-4.0.7.ebuild b/dev-python/jupyterlab/jupyterlab-4.0.7.ebuild
new file mode 100644
index 000000000000..a329291d6048
--- /dev/null
+++ b/dev-python/jupyterlab/jupyterlab-4.0.7.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1 pypi xdg
+
+DESCRIPTION="JupyterLab computational environment"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab/
+ https://pypi.org/project/jupyterlab/
+"
+
+LICENSE="BSD MIT GPL-3 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/async-lru[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+ dev-python/jupyter-core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-server-2.19[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-server-3[${PYTHON_USEDEP}]
+ >=dev-python/notebook-shim-0.2[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ net-libs/nodejs
+"
+
+BDEPEND="
+ dev-python/hatch-jupyter-builder[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-cache[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # These tests call npm and want internet
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_uninstall_core_extension
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned_folder
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom_minimal_core_config
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_check
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_clear
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_build
+)
+
+EPYTEST_IGNORE=(
+ jupyterlab/tests/test_announcements.py
+)
+
+distutils_enable_tests pytest
+# TODO: package sphinx_copybutton
+#distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme dev-python/myst-parser
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}