summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab/jupyterlab-3.4.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-14 06:50:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-14 06:50:14 +0000
commitafa8da78d8135ca28150730e9c60af9d875f0a5b (patch)
tree65e94479f29d7591a1bc1d09d1fc1913d785fe6b /dev-python/jupyterlab/jupyterlab-3.4.8.ebuild
parent4828c25c25aacf399de429d381288982fd7e0d0e (diff)
gentoo auto-resync : 14:11:2022 - 06:50:13
Diffstat (limited to 'dev-python/jupyterlab/jupyterlab-3.4.8.ebuild')
-rw-r--r--dev-python/jupyterlab/jupyterlab-3.4.8.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/jupyterlab/jupyterlab-3.4.8.ebuild b/dev-python/jupyterlab/jupyterlab-3.4.8.ebuild
deleted file mode 100644
index 1491c0f13490..000000000000
--- a/dev-python/jupyterlab/jupyterlab-3.4.8.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_PEP517=jupyter
-inherit distutils-r1
-
-DESCRIPTION="JupyterLab computational environment"
-HOMEPAGE="https://jupyter.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD MIT GPL-3 Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-BDEPEND="dev-python/jupyter_packaging[${PYTHON_USEDEP}]"
-
-RDEPEND="
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/jupyter_core[${PYTHON_USEDEP}]
- >=dev-python/jupyterlab_server-2.10[${PYTHON_USEDEP}]
- >=dev-python/jupyter_server-1.16[${PYTHON_USEDEP}]
- >=dev-python/nbclassic-0.2[${PYTHON_USEDEP}]
- <dev-python/notebook-7[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.1[${PYTHON_USEDEP}]
- >=dev-python/tornado-6.1[${PYTHON_USEDEP}]
- dev-python/tomli[${PYTHON_USEDEP}]
- net-libs/nodejs
-"
-
-BDEPEND="test? (
- dev-python/check-manifest[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/jupyterlab_server[${PYTHON_USEDEP}]
- dev-python/openapi-core[${PYTHON_USEDEP}]
- dev-python/openapi-spec-validator[${PYTHON_USEDEP}]
- dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
- dev-python/pytest-tornasync[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- dev-python/requests-cache[${PYTHON_USEDEP}]
- dev-python/strict-rfc3339[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
-)"
-
-EPYTEST_DESELECT=(
- # These tests call npm and want internet
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_uninstall_core_extension
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned_folder
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom_minimal_core_config
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_check
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build
- jupyterlab/tests/test_build_api.py::TestBuildAPI::test_clear
- jupyterlab/tests/test_build_api.py::TestBuildAPI::test_build
-)
-
-distutils_enable_tests pytest
-# TODO: package sphinx_copybutton
-#distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme dev-python/myst_parser
-
-python_install_all() {
- distutils-r1_python_install_all
- mv "${ED}/usr/etc" "${ED}/etc" || die
-}