summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab-widgets
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-06 00:07:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-06 00:07:58 +0100
commit44cec61076bf2bbb3cea1fc89943dd6818a5acc5 (patch)
tree68f1cddcf97a0d746c1e9c186171b7bd603efccf /dev-python/jupyterlab-widgets
parent9d1e33edaf09cde926d589461f40e378d4124be9 (diff)
gentoo auto-resync : 06:06:2024 - 00:07:57
Diffstat (limited to 'dev-python/jupyterlab-widgets')
-rw-r--r--dev-python/jupyterlab-widgets/Manifest5
-rw-r--r--dev-python/jupyterlab-widgets/jupyterlab-widgets-3.0.10.ebuild25
-rw-r--r--dev-python/jupyterlab-widgets/jupyterlab-widgets-3.0.11.ebuild25
-rw-r--r--dev-python/jupyterlab-widgets/metadata.xml17
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-widgets/Manifest b/dev-python/jupyterlab-widgets/Manifest
new file mode 100644
index 000000000000..216380b27a65
--- /dev/null
+++ b/dev-python/jupyterlab-widgets/Manifest
@@ -0,0 +1,5 @@
+DIST jupyterlab_widgets-3.0.10.tar.gz 205549 BLAKE2B 7f31ffa65a6478f4007449fd9f1ea749144eda39afe21208b934fc33b2222e605a21e1cbfd61961b48c001b780eb75425444729fec931bb7fbb7f9afa290971d SHA512 a68de696b9d8c332c796242dd72d1a0cc33944373e97c826b8a971eb558565e55f4a0a59ba437e9bb9466695755193aa95ec74d69e54628931858f524c939da5
+DIST jupyterlab_widgets-3.0.11.tar.gz 203538 BLAKE2B 8208afd3dc9e8dd36a6ab77ac20d935b53a8c200401e9e423ca154e87c50379cced5ff785dc625ead7f09aaffd9af5835151a853224abce6e7c84c6ce199259e SHA512 27e8fec4817d3e37e1976c30db21f914b11dc3bb1e0aa7c584c811b3f9a54422136c7702bd32f7494851d87108182a8a9fe11686d515f4da19ee2a8f7a930755
+EBUILD jupyterlab-widgets-3.0.10.ebuild 529 BLAKE2B 30210605fa94afba6256716eb442c6249325eb1879eb46c7925a963971c82432b8311ca66152750ef21b4cad32ecac390a0c15ad994196eb53298c350e4a6f38 SHA512 69aa62b72e068b3f2ae5e6ff314709ff458019fa14b07439a3a0adfdae9ba915af7ad75ae367f71106a17919755be7f00a4485f5a72a6db1a9ba6c95c2f31ff1
+EBUILD jupyterlab-widgets-3.0.11.ebuild 529 BLAKE2B 30210605fa94afba6256716eb442c6249325eb1879eb46c7925a963971c82432b8311ca66152750ef21b4cad32ecac390a0c15ad994196eb53298c350e4a6f38 SHA512 69aa62b72e068b3f2ae5e6ff314709ff458019fa14b07439a3a0adfdae9ba915af7ad75ae367f71106a17919755be7f00a4485f5a72a6db1a9ba6c95c2f31ff1
+MISC metadata.xml 545 BLAKE2B e118a018413f28e1e793c14f26b1446f756ed0a17f4b8d7f93e3271300ce02ebffdff931356378f49c846aea0f3d01ebaa1aa13fbe4b914dfb47ca9cdff61ca8 SHA512 84e8c0c8fc095dff538d2acbe47065490228b2a833e8823e5462395aded8860472bf854389faf58ceeac758cd8d2256da58c738db6c86e22e9bb0f93dfefabfe
diff --git a/dev-python/jupyterlab-widgets/jupyterlab-widgets-3.0.10.ebuild b/dev-python/jupyterlab-widgets/jupyterlab-widgets-3.0.10.ebuild
new file mode 100644
index 000000000000..aba851fa4397
--- /dev/null
+++ b/dev-python/jupyterlab-widgets/jupyterlab-widgets-3.0.10.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=jupyter
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter interactive widgets for JupyterLab"
+HOMEPAGE="
+ https://ipython.org/
+ https://pypi.org/project/jupyterlab-widgets/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ >=dev-python/jupyterlab-4.1.8[${PYTHON_USEDEP}]
+ dev-python/jupyter-packaging[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/jupyterlab-widgets/jupyterlab-widgets-3.0.11.ebuild b/dev-python/jupyterlab-widgets/jupyterlab-widgets-3.0.11.ebuild
new file mode 100644
index 000000000000..aba851fa4397
--- /dev/null
+++ b/dev-python/jupyterlab-widgets/jupyterlab-widgets-3.0.11.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=jupyter
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter interactive widgets for JupyterLab"
+HOMEPAGE="
+ https://ipython.org/
+ https://pypi.org/project/jupyterlab-widgets/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ >=dev-python/jupyterlab-4.1.8[${PYTHON_USEDEP}]
+ dev-python/jupyter-packaging[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/jupyterlab-widgets/metadata.xml b/dev-python/jupyterlab-widgets/metadata.xml
new file mode 100644
index 000000000000..c648ebb8fde1
--- /dev/null
+++ b/dev-python/jupyterlab-widgets/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">jupyterlab-widgets</remote-id>
+ <remote-id type="github">jupyter-widgets/ipywidgets</remote-id>
+ </upstream>
+</pkgmetadata>