summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab-pygments
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-23 16:28:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-23 16:28:44 +0000
commit191f9d51469a31970723ed9eb0aee70ffe63094e (patch)
tree2502e164870943a5ca491043010657f1b83e4a27 /dev-python/jupyterlab-pygments
parent2114f9bc3d55c52f926a43f08765b350871e86f2 (diff)
gentoo auto-resync : 23:11:2023 - 16:28:43
Diffstat (limited to 'dev-python/jupyterlab-pygments')
-rw-r--r--dev-python/jupyterlab-pygments/Manifest2
-rw-r--r--dev-python/jupyterlab-pygments/jupyterlab-pygments-0.3.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-pygments/Manifest b/dev-python/jupyterlab-pygments/Manifest
index 2d2fbdbbc40a..97dba0ee890f 100644
--- a/dev-python/jupyterlab-pygments/Manifest
+++ b/dev-python/jupyterlab-pygments/Manifest
@@ -1,3 +1,5 @@
DIST jupyterlab_pygments-0.2.2.tar.gz 132378 BLAKE2B a9db4c3bfea9e8e6f357c90e9b1861cf2bcb796fe5d7ea9a0f02677773b18dd5a02966d8555cd17e8314b283056ac9423948077d6cdc127985f34a5faf892ec1 SHA512 59d328522b11ecae6ae67ef8f9eb7168b0e4241cc6a68765096bf0ad26a20489f302179d50e7e46efd5b9de711520e2c67ab1e634cc583416277a98a5f663daa
+DIST jupyterlab_pygments-0.3.0-py3-none-any.whl 15884 BLAKE2B 09c7190853999513a326464de056e8aa5e0bbe02713c42a4e3dc05f67153891fef78388799465293d40b4069c2d9d1b45eaea5c1a92b10e069e4bf88308247b3 SHA512 12132631d0e35c9698c60370277325ffaaeb967314c8c4cf820045b0f6138e860682699381fce4a37402ecf0854bac344c4be22d15c1d543bebdbb4cf8f43d9b
EBUILD jupyterlab-pygments-0.2.2.ebuild 552 BLAKE2B 8905c96361987a9ea74afbd2e8ee26559f57e5d4ae7f24313b20a9e59b39084026a02571f0f3eeeb684e07b59a3fc1f83f229c025b1a9150e5e5863527fe8fb7 SHA512 474d07237acbdbee6ead7b58860a320d4810e638119b16fb2547a45df61b4482b8985dea03f0e3c0bd8f299b56b8a9eb7c63f1ff84a4f09e8b05546c82ea0ab5
+EBUILD jupyterlab-pygments-0.3.0.ebuild 710 BLAKE2B cb4960e154412f0d6038236fab02897c29e928a186638bde6018b0dcba2358b4dd5c0ea7fdd590cdd3433dc736ba765c0d85b03a87da3291d30083993d203948 SHA512 c7bfcb6e234dbae0d1c7a0080627bf14f60f2b23ae5ba1643c6c8c9ccaf5967168dbc0062957bfa62975a1a8136fe0f3fd31ceb5bdf2b0aa189946cc278bf15d
MISC metadata.xml 395 BLAKE2B 61c5b49ef1984252b5be03231c068df3c46d4326368f3d5166d416e20fc29e6fe8356d6e6f3767f61a05154d42f86407ebab060ebf01a742fd082e62d65469b0 SHA512 9eac2fc382341fec3e344fdfc8365e022b9890739419e8f63bdee313293acc18fe75e40234c26b649396f1e164c32e1a7cd43ea26216c24b610bf495db0c5318
diff --git a/dev-python/jupyterlab-pygments/jupyterlab-pygments-0.3.0.ebuild b/dev-python/jupyterlab-pygments/jupyterlab-pygments-0.3.0.ebuild
new file mode 100644
index 000000000000..011c3409a41f
--- /dev/null
+++ b/dev-python/jupyterlab-pygments/jupyterlab-pygments-0.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pygments theme making use of JupyterLab CSS variables"
+HOMEPAGE="
+ https://pypi.org/project/jupyterlab-pygments/
+ https://github.com/jupyterlab/jupyterlab_pygments/
+"
+SRC_URI="$(pypi_wheel_url)"
+S=${WORKDIR}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ distutils_wheel_install "${BUILD_DIR}/install" \
+ "${DISTDIR}/$(pypi_wheel_name)"
+}