summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab-lsp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-27 22:51:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-27 22:51:10 +0000
commitee0c4d5e506a6c64994a15c3af5cf1ca22045567 (patch)
treebdf578939023d42f04092ddb4bcd190eb391770f /dev-python/jupyterlab-lsp
parent161eaa4b12ca6314376288834bba20b7824d0d77 (diff)
gentoo auto-resync : 27:11:2023 - 22:51:09
Diffstat (limited to 'dev-python/jupyterlab-lsp')
-rw-r--r--dev-python/jupyterlab-lsp/Manifest2
-rw-r--r--dev-python/jupyterlab-lsp/jupyterlab-lsp-5.0.1.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-lsp/Manifest b/dev-python/jupyterlab-lsp/Manifest
index 263d41a971ef..c2376c46bb30 100644
--- a/dev-python/jupyterlab-lsp/Manifest
+++ b/dev-python/jupyterlab-lsp/Manifest
@@ -1,3 +1,5 @@
DIST jupyterlab-lsp-5.0.0.tar.gz 753429 BLAKE2B bd9fac94edea990943ce839c773270f14a5afd646b312c3c6888a0230c2846968388862c01c4954830d85c3eebcd6699aed79cc7861e4fb8d19d576cf0ba938b SHA512 a6e586cf19707a6aec91f495fbb437ce2aaa6b827964c06d4479d056b0a8eca525c46a3e3e8c7891e0f486cde9b63416a80188c623f71948e4b1658a751d98b1
+DIST jupyterlab-lsp-5.0.1.tar.gz 755832 BLAKE2B d8082aaf9c1219fedeebd6a717b81f08a7bba2a8618dc99b2ecf9a6d28c4e6cbf34b711c4fae4a847675ea05d2dc7acd0c812a772e9d51f37f563d088398c088 SHA512 7fef1ab7309978aa9185afdc895a7adefc72210842228d055150b231b70980e772abf166762820971f653cf0f5abd65e9bdfe3a206c4aed99b4586fec684399e
EBUILD jupyterlab-lsp-5.0.0.ebuild 610 BLAKE2B a3a22db791094f4bcb0dc6bd27cc542e11de8eb983b3aef6242e074ac5fb215629dd03d5fa86603e68669c23989225f63e7faff406819aeffb4126f169b64464 SHA512 7022cddb4d094b00c5e0ce341ebc38aced71410aba3f2ce1d0add8ade31d27c3b2caa930d7d394153d49ae0f1429d9e5426b633303215b39367d589fcd020078
+EBUILD jupyterlab-lsp-5.0.1.ebuild 610 BLAKE2B a3a22db791094f4bcb0dc6bd27cc542e11de8eb983b3aef6242e074ac5fb215629dd03d5fa86603e68669c23989225f63e7faff406819aeffb4126f169b64464 SHA512 7022cddb4d094b00c5e0ce341ebc38aced71410aba3f2ce1d0add8ade31d27c3b2caa930d7d394153d49ae0f1429d9e5426b633303215b39367d589fcd020078
MISC metadata.xml 421 BLAKE2B cbd9c4e3ce5848ed3d0e57832082dd730d2d16a286070639602b8fcd49c49714e7f17b220251b9f16d9c5105248933390b152c060c68522d2c82b1958b09b116 SHA512 97ac68ac4e6920f23120a5818b4404fa0b510b165a44a6455a7bf76edfa298ca137f50bd9c1a87044253f5b873f881362c2667261a4c7fdb182a7d37325520b3
diff --git a/dev-python/jupyterlab-lsp/jupyterlab-lsp-5.0.1.ebuild b/dev-python/jupyterlab-lsp/jupyterlab-lsp-5.0.1.ebuild
new file mode 100644
index 000000000000..41562289e7f4
--- /dev/null
+++ b/dev-python/jupyterlab-lsp/jupyterlab-lsp-5.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Coding assistance for JupyterLab with Language Server Protocol"
+HOMEPAGE="
+ https://github.com/jupyter-lsp/jupyterlab-lsp/
+ https://pypi.org/project/jupyterlab-lsp/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jupyterlab-4.0.0[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-2.0.0[${PYTHON_USEDEP}]
+"