summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_ydoc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-13 14:17:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-13 14:17:04 +0000
commitfb12f951d1a9071b4ddf774f2d570de245c2d061 (patch)
tree12b4074e61af9ee7b74753f5249f2362dd1060bf /dev-python/jupyter_ydoc
parent4a74938e510c0dad732ae4c48f815dd0f0cabb46 (diff)
gentoo auto-resync : 13:02:2023 - 14:17:03
Diffstat (limited to 'dev-python/jupyter_ydoc')
-rw-r--r--dev-python/jupyter_ydoc/Manifest2
-rw-r--r--dev-python/jupyter_ydoc/jupyter_ydoc-0.2.2.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/jupyter_ydoc/Manifest b/dev-python/jupyter_ydoc/Manifest
index c3ac7fcdfd8c..6c4f1e1ac0b5 100644
--- a/dev-python/jupyter_ydoc/Manifest
+++ b/dev-python/jupyter_ydoc/Manifest
@@ -1,4 +1,6 @@
AUX jupyter_ydoc-0.3.1-no-node-for-version.patch 846 BLAKE2B e2db718c5c7f1fd04a720e0eed00158bf657b931462274090740d6a11d37b7dc4e1493414e0490ace783ff91c01cd052fad00db1651192eb6fd1618ab68fc420 SHA512 827b79a02c933b902d75aeb997b6abd25a867b0ef978f2ba78f689897545552560d31e472207b6048b63605db40799eb5b10cfaf0b502c621278a48f96ac6a22
+DIST jupyter_ydoc-0.2.2.gh.tar.gz 10664 BLAKE2B d8a0536c07097e359b0145e5ca08f203dcc06d6ff1f556b814cebb5d8798dcd0ca36f70c010f410f4c14a754989db7dc65255863ea7c2610f0201820917f0e90 SHA512 f8db63a1829ffd58c8e773a2c9be674023e58a57dbd7bfffdfaf37ee735bf6cbd62c984df830198b1e8bdd5d1bcb1679cef07a77af36b02c72a704d6e9e295ca
DIST jupyter_ydoc-0.3.1.gh.tar.gz 170182 BLAKE2B 6a3b000b47bb00ddb8f6ddecb1091a150dbb33dadcb8ecfe8d55a03050663ee9dacbe1b8063174f54cca5472a6245951ba8ce3137afedea17735d1c5679690fc SHA512 897779f39cf2ffb0e59db31745063d2482d165ee76ca4cedb131b8daed341a63826af150a6da013226febc99d1bd0376fc003ff179744e81ec619993c04ffdd0
+EBUILD jupyter_ydoc-0.2.2.ebuild 1023 BLAKE2B 63cdfca42641af7171b46929865e566a724da6500f70e16b50dd9e22273a11e271508150b4dacc0ad29d4f3d7b31383d3c131fadf2413d0a6bee4c98a997f78b SHA512 87951f813afc6e462c6c80192db7dd5bed9da14244d07747c83f64d2f01fe866e7d9c808bb9b353cec2ed450477cd2236683e016eca49c6102a05acbc39c0ef5
EBUILD jupyter_ydoc-0.3.1.ebuild 1075 BLAKE2B 727cafaa76ba2b0ddb12d7f0990e820808785081f783e256f3137c1dee52212a8d4ec0f9af4c0756b3bb88e90004cf1baa6fc8de0a3e572a3c43c1ffc3b4a13b SHA512 0383dc0484e249b32dae9bb495fed02cb44b5af6cd162f575e5fdc4f7f4f2a42e19b27604a2b6562a1413f91781332cf03bdb35fcb8b22642af3febc21b30a05
MISC metadata.xml 433 BLAKE2B cf2579c7d85eefe97d8ec81f37ac5e10deee9aaf52b16cea8ce3649f6076a3afee9e7ce6efbf82cd7713421353b53c16ed4d28b03a9b6e8b5c029fc6f3615651 SHA512 1258a3f0bd2a959055312594eb72bcd06fd639cf777543b41919da60b4082d241ad87231bdfb8c2ef057c85657875ac596b732301d3fb0c9a10cea5d2746234f
diff --git a/dev-python/jupyter_ydoc/jupyter_ydoc-0.2.2.ebuild b/dev-python/jupyter_ydoc/jupyter_ydoc-0.2.2.ebuild
new file mode 100644
index 000000000000..42240178e1de
--- /dev/null
+++ b/dev-python/jupyter_ydoc/jupyter_ydoc-0.2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Document structures for collaborative editing using Ypy"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/jupyter_ydoc/
+ https://pypi.org/project/jupyter-ydoc/
+"
+SRC_URI="https://github.com/jupyter-server/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Requires node
+RESTRICT="test"
+
+RDEPEND="
+ <dev-python/y-py-0.6.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ dev-python/ypy-websocket[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# Hangs for some reason
+#distutils_enable_sphinx docs/source dev-python/myst_parser dev-python/pydata-sphinx-theme