summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_ydoc/jupyter_ydoc-0.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-python/jupyter_ydoc/jupyter_ydoc-0.3.1.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-python/jupyter_ydoc/jupyter_ydoc-0.3.1.ebuild')
-rw-r--r--dev-python/jupyter_ydoc/jupyter_ydoc-0.3.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/jupyter_ydoc/jupyter_ydoc-0.3.1.ebuild b/dev-python/jupyter_ydoc/jupyter_ydoc-0.3.1.ebuild
new file mode 100644
index 000000000000..ea9984a94ac7
--- /dev/null
+++ b/dev-python/jupyter_ydoc/jupyter_ydoc-0.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Document structures for collaborative editing using Ypy"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/jupyter_ydoc/
+ https://pypi.org/project/jupyter-ydoc/
+"
+SRC_URI="https://github.com/jupyter-server/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Requires node
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/y-py[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ dev-python/ypy-websocket[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-node-for-version.patch"
+)
+
+distutils_enable_tests pytest
+# Hangs for some reason
+#distutils_enable_sphinx docs/source dev-python/myst_parser dev-python/pydata-sphinx-theme