summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_packaging
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-25 23:34:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-25 23:34:28 +0100
commit5b14ea000f5782ac047162ffc35ef8c3c0648b4a (patch)
tree9bd4130367f85e9308e6d6c6b12ba58759b5f789 /dev-python/jupyter_packaging
parent85261a4d217482e1c124937d57ec98a0aabaee59 (diff)
gentoo auto-resync : 25:09:2022 - 23:34:28
Diffstat (limited to 'dev-python/jupyter_packaging')
-rw-r--r--dev-python/jupyter_packaging/Manifest4
-rw-r--r--dev-python/jupyter_packaging/jupyter_packaging-0.12.2.ebuild43
-rw-r--r--dev-python/jupyter_packaging/jupyter_packaging-0.12.3.ebuild2
3 files changed, 2 insertions, 47 deletions
diff --git a/dev-python/jupyter_packaging/Manifest b/dev-python/jupyter_packaging/Manifest
index a05214e7b48d..4f603000f683 100644
--- a/dev-python/jupyter_packaging/Manifest
+++ b/dev-python/jupyter_packaging/Manifest
@@ -1,5 +1,3 @@
-DIST jupyter_packaging-0.12.2.tar.gz 27990 BLAKE2B 0cd07fa760fe0bd4529e8430bd52863034cc4c78d8f906f55530a6825c496b8a1bf2fff76da3f4e963ee43c80fc19347edbaf20d16fbfe51584b040b0ab4d3ed SHA512 f4167c7beb3188d2e4b0fa8601fb8cdede8b20dc8c16e0bccbcf9e317e75e24ea1469a9d904bb35b2d81dec351caf49526ef35e5d91460a099a8e4ed6974e1b1
DIST jupyter_packaging-0.12.3.tar.gz 25350 BLAKE2B 62c9f35a3008f8252f8ae8a55b2f7156fc98347b48dbe9bf08101b9c9b0cc892886cf248e0d916455f472bd5130dacccbfb9e206818c5f096eb759bb6149f758 SHA512 a81a4b41ba7b31b9d71aa338617ed8567100a64d999e6cd0a14586350bcd37bf9782cbaabad755c0303510bd342ec141af01157cbdc1e4373289700dfc40c3c9
-EBUILD jupyter_packaging-0.12.2.ebuild 1036 BLAKE2B 3c9f32cf7a46e88b61ce836c8d6ec053e86edf684f4412c8ad4fb038eb80c2120d0fc1e3fd2f6571cda1c510212c86fb3c6ebfdd6c46bc9ad7027b1546fcb46b SHA512 2f3ac5cbb9a7fefc31c8f4b458cb6d8014b299435e52b5839ad8e06091cd3630c506bc17cfc827358196df3cca182fc79dcd9dc2fea24d3a0223b639d07afbe0
-EBUILD jupyter_packaging-0.12.3.ebuild 1044 BLAKE2B da3689ecc34d35f9260c0bf53be9161d8637a30ecfeaeffd6af4b340bcf0371419d7200e15d3e918611cd30fe60ccf379a4d4232dd10feb367cc88e78c738480 SHA512 8383b60b04010967608208556aee03294356aa91f6b390aa67dd97a319517440745edf0ff9bdda0a89aeb0f87808de288406afff497954a7d2646548525ec4e1
+EBUILD jupyter_packaging-0.12.3.ebuild 1036 BLAKE2B 3c9f32cf7a46e88b61ce836c8d6ec053e86edf684f4412c8ad4fb038eb80c2120d0fc1e3fd2f6571cda1c510212c86fb3c6ebfdd6c46bc9ad7027b1546fcb46b SHA512 2f3ac5cbb9a7fefc31c8f4b458cb6d8014b299435e52b5839ad8e06091cd3630c506bc17cfc827358196df3cca182fc79dcd9dc2fea24d3a0223b639d07afbe0
MISC metadata.xml 543 BLAKE2B f22c42fcc55d0a26966abd01c5e4fe480edff112a2e34ecf0214a2f1b50c120f937a6d377a544136e1cd55e89216efc0a9788ed6aeef8403e4e30a15d9d9af12 SHA512 3243614660159c0c7afed90cc084e4c0c7d85d71628f437ee1ecfa84c9a080f27cff92c5a40a134e579e03b93a1777232add591c7f36262d5bb3e7ec83b6441d
diff --git a/dev-python/jupyter_packaging/jupyter_packaging-0.12.2.ebuild b/dev-python/jupyter_packaging/jupyter_packaging-0.12.2.ebuild
deleted file mode 100644
index 68c1904798c8..000000000000
--- a/dev-python/jupyter_packaging/jupyter_packaging-0.12.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Tools to help build and install Jupyter Python packages"
-HOMEPAGE="
- https://jupyter.org/
- https://github.com/jupyter/jupyter-packaging/
- https://pypi.org/project/jupyter-packaging/
-"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/setuptools-60.2.0[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- dev-python/deprecation[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/build[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # require Internet
- tests/test_build_api.py::test_build_package
- tests/test_build_api.py::test_deprecated_metadata
-)
diff --git a/dev-python/jupyter_packaging/jupyter_packaging-0.12.3.ebuild b/dev-python/jupyter_packaging/jupyter_packaging-0.12.3.ebuild
index 60f174880fc1..68c1904798c8 100644
--- a/dev-python/jupyter_packaging/jupyter_packaging-0.12.3.ebuild
+++ b/dev-python/jupyter_packaging/jupyter_packaging-0.12.3.ebuild
@@ -18,7 +18,7 @@ SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
dev-python/packaging[${PYTHON_USEDEP}]