summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_core/jupyter_core-4.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /dev-python/jupyter_core/jupyter_core-4.7.1.ebuild
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'dev-python/jupyter_core/jupyter_core-4.7.1.ebuild')
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.7.1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/jupyter_core/jupyter_core-4.7.1.ebuild b/dev-python/jupyter_core/jupyter_core-4.7.1.ebuild
deleted file mode 100644
index 9e966dfd2d97..000000000000
--- a/dev-python/jupyter_core/jupyter_core-4.7.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Core common functionality of Jupyter projects"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="dev-python/traitlets[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_sphinx docs \
- dev-python/sphinxcontrib-github-alt
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # fails if jupyter is not in system sitedir
- # (PYTHONPATH is insufficient)
- jupyter_core/tests/test_command.py::test_not_on_path
- jupyter_core/tests/test_command.py::test_path_priority
- # TODO
- jupyter_core/tests/test_paths.py::test_jupyter_path_prefer_env
- )
-
- pytest -vv ${deselect[@]/#/--deselect } ||
- die "Tests failed with ${EPYTHON}"
-}