summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_console/jupyter_console-6.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-21 20:25:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-21 20:25:12 +0000
commitd37f8725bb68034ef10d8882fb4411a49f2f666e (patch)
tree2b530ee04815bacc1dc051db24c2727d3056b77b /dev-python/jupyter_console/jupyter_console-6.6.1.ebuild
parent171d09fa1f429aa43835c618a2c21753ad5209a4 (diff)
gentoo auto-resync : 21:02:2023 - 20:25:12
Diffstat (limited to 'dev-python/jupyter_console/jupyter_console-6.6.1.ebuild')
-rw-r--r--dev-python/jupyter_console/jupyter_console-6.6.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/jupyter_console/jupyter_console-6.6.1.ebuild b/dev-python/jupyter_console/jupyter_console-6.6.1.ebuild
new file mode 100644
index 000000000000..df81535d9bc2
--- /dev/null
+++ b/dev-python/jupyter_console/jupyter_console-6.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A terminal-based console frontend for Jupyter kernels"
+HOMEPAGE="https://jupyter.org"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-7.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/prompt-toolkit-3.0.30[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.4[${PYTHON_USEDEP}]
+"
+# util-linux provides script(1)
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ sys-apps/util-linux
+ )
+"
+
+distutils_enable_tests pytest