summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_client/jupyter_client-6.1.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-python/jupyter_client/jupyter_client-6.1.12.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-python/jupyter_client/jupyter_client-6.1.12.ebuild')
-rw-r--r--dev-python/jupyter_client/jupyter_client-6.1.12.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/dev-python/jupyter_client/jupyter_client-6.1.12.ebuild b/dev-python/jupyter_client/jupyter_client-6.1.12.ebuild
index 8743d8a22758..b5a1d4b89ec7 100644
--- a/dev-python/jupyter_client/jupyter_client-6.1.12.ebuild
+++ b/dev-python/jupyter_client/jupyter_client-6.1.12.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="threads(+)"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
inherit distutils-r1
DESCRIPTION="Jupyter protocol implementation and client libraries"
@@ -15,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~sparc x86"
+KEYWORDS="amd64 ~arm arm64 ~riscv ~sparc x86"
RDEPEND="
dev-python/async_generator[${PYTHON_USEDEP}]
@@ -33,3 +31,11 @@ BDEPEND="
)"
distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ jupyter_client/tests/test_kernelmanager.py::TestAsyncKernelManager::test_signal_kernel_subprocesses
+ jupyter_client/tests/test_kernelmanager.py::TestAsyncKernelManager::test_start_new_async_kernel
+ )
+ epytest ${deselect[@]/#/--deselect }
+}