summaryrefslogtreecommitdiff
path: root/dev-python/jupyter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/jupyter
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/jupyter')
-rw-r--r--dev-python/jupyter/Manifest1
-rw-r--r--dev-python/jupyter/jupyter-1.0.0-r4.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/jupyter/Manifest b/dev-python/jupyter/Manifest
index 3e71462207ae..a229024bf372 100644
--- a/dev-python/jupyter/Manifest
+++ b/dev-python/jupyter/Manifest
@@ -1,4 +1,5 @@
DIST jupyter-1.0.0-file-colision.patch 1727 BLAKE2B 59bf5e567e6da9e9f3d84178942993072e1697c1c4c06e06d606dce7bdc76d296d10c30cdef2865bce7b4c26136a1b0a2860f009f1530c1815b48b3300401501 SHA512 a6b4cc6b91bb9941f029963cc3e3b7f415192f64788a34dde7828d450497987f92c25655c5ca183a7408fb1fb439917ba0f0a1ef1db3fe3bec1fc46d9ad2cf4d
DIST jupyter-1.0.0.tar.gz 12916 BLAKE2B 36476eaf0119613ba6d9f153aab1658f43951dc3879cb6a9e90d8fba14cc1247305e18fda2251127faac4e68867efd3ef57129675bbe89a17a6469255efcade2 SHA512 1f0bc83f7a127c98ccf4b3868814116aa272ea5d0baac52d7a022305af7e2da28ca2b90fa3554ff085d8df3eb6d8b8cde80bf02b8e66064c59900b926d73c520
EBUILD jupyter-1.0.0-r3.ebuild 1149 BLAKE2B f0a19771de1793672e29e9c63de75201e5aa5c2f098e6ae3964eec9b005afd3e92bf8be00d2b2eb660b72873270921faf44b377185f1ef4523098e4794afa6f3 SHA512 6103c4d83e600c0eb3f23e88d81bab911be978ddff9fa0541c92918c13e9198b0c9e6006200aa88170dbe8198fd29e84c47719938d121fe5abb4dde7eee7d721
+EBUILD jupyter-1.0.0-r4.ebuild 955 BLAKE2B d3cbc124db74fe31860b590f4d414c2c911f61119bdb023e38b6ea68434e6e686282a807cf5a7635e9ad0ab196ab78c71e0b1fd6adb3a718a762a2f71eab0533 SHA512 dabc550dc7626e3253773efbe08029c512c64e4046af363c90047b36e1c6b9f9bc73ab98dee58923e8409a135db936f56a848651da464bab410fabb19e4f40cc
MISC metadata.xml 391 BLAKE2B af2c9f38e30fca600dbd7c482a5d3c10e11463e5359e59630126d2848dc776bff78c79deeba97e1d8a4074f5aa597acc1b29a1bf5007e213657a4e428d07e36d SHA512 090a9c06ac5e0a451769e99a92db93cc6880cfe76bc485d09c60f2f6870723c4c91f898ac6d28a1c9691b7e9a0e98568368ec3b7ecf2e51decef7728fd79d40d
diff --git a/dev-python/jupyter/jupyter-1.0.0-r4.ebuild b/dev-python/jupyter/jupyter-1.0.0-r4.ebuild
new file mode 100644
index 000000000000..dff5487ba45c
--- /dev/null
+++ b/dev-python/jupyter/jupyter-1.0.0-r4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter metapackage. Install all the Jupyter components in one go"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://patch-diff.githubusercontent.com/raw/jupyter/jupyter/pull/198.patch -> ${P}-file-colision.patch
+ "
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/qtconsole[${PYTHON_USEDEP}]
+ dev-python/jupyter_console[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]"
+PDEPEND=">=dev-python/jupyter_core-4.2.0[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+
+PATCHES=( "${DISTDIR}"/${P}-file-colision.patch )