summaryrefslogtreecommitdiff
path: root/dev-python/jupyter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/jupyter
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/jupyter')
-rw-r--r--dev-python/jupyter/Manifest6
-rw-r--r--dev-python/jupyter/jupyter-1.0.0-r1.ebuild50
-rw-r--r--dev-python/jupyter/jupyter-1.0.0.ebuild44
-rw-r--r--dev-python/jupyter/metadata.xml15
4 files changed, 115 insertions, 0 deletions
diff --git a/dev-python/jupyter/Manifest b/dev-python/jupyter/Manifest
new file mode 100644
index 000000000000..0f152d0d06db
--- /dev/null
+++ b/dev-python/jupyter/Manifest
@@ -0,0 +1,6 @@
+DIST jupyter-1.0.0-file-colision.patch 1727 SHA256 a88e50d5aba792e87566c74991023017e04324f728f628b3e45b8ba05feb9140 SHA512 a6b4cc6b91bb9941f029963cc3e3b7f415192f64788a34dde7828d450497987f92c25655c5ca183a7408fb1fb439917ba0f0a1ef1db3fe3bec1fc46d9ad2cf4d WHIRLPOOL 3690b872d910ed8e4615780e868c566f1f36c84fa11c33b25f2b9380a7f201a5c99aae9e29a0e6fb068494ff32babb257f20f773c7af901f25226ac1fd40767d
+DIST jupyter-1.0.0.tar.gz 12916 SHA256 d9dc4b3318f310e34c82951ea5d6683f67bed7def4b259fafbfe4f1beb1d8e5f SHA512 1f0bc83f7a127c98ccf4b3868814116aa272ea5d0baac52d7a022305af7e2da28ca2b90fa3554ff085d8df3eb6d8b8cde80bf02b8e66064c59900b926d73c520 WHIRLPOOL c648e494556f6d5d3a42594bb4c2fd5701b2f993cf467d6011f67141de2e80d6cccf1adfcfcda6445d8325604e67d6af4465b6e2d79443de67512a2a29360855
+EBUILD jupyter-1.0.0-r1.ebuild 1300 SHA256 dbabe4812cd58329f1bb1d7bab08c0f58890d5fa2fb1fc51fa0aad7d61b2d51c SHA512 24571554e886d5589fd845a7ee576515ebbe9d3f73e6afcb4ea6020fc6da3df5ef37083c7d4e9a6959a346513cac085545ee9006e784c4456222a011754b0715 WHIRLPOOL 6b15133dcc810e305233f55bec33fd44164f76c9c8e9d6b37cd5151fac5b28cf0196846def93d0b5f9fb0911a31260d8bb739ffbe94b697945d22d7a7d0641ff
+EBUILD jupyter-1.0.0.ebuild 1075 SHA256 d306591d0c978b1e1d65ea6ec10e7346b8ba0259ffaac19b1eb625b00361d824 SHA512 34ff80f3d9f05e1798c83b17e756682ed8142ca0180fba8401fddbb7d0ed3c1b57c92addaf35f81e41623fd0df3621168ab9acadf5dfce3ee7e544b9547f9797 WHIRLPOOL 6834eedeac41bf94765dfa0c2936cc69613293816a057b9f6a9e29acf1362854ddd530e7de94b39873c88aa45bd926f916b53879a5a01e5f25ad5a901ce7bde1
+MISC ChangeLog 1139 SHA256 b25ea3bc9f82f81a7833a60e9eb9f2faf37e8766f01abb66ec0f958a9842147e SHA512 a83bf5d781d4745130272b7e2376aa9ed3c95c75511f01f2a046fbbb487eff9075b853c43142d80043447efdbc4c082f3fe843a44f63ea62a6d752ac2a9694bb WHIRLPOOL 7f3c5cedfdb2b4b5c48041f37ac49aca88be21223734f401f7d816221b71955657dfea32e5e68e5954c7eabcf5e76057cc517553546617da2ddbc61ed7d0bc40
+MISC metadata.xml 518 SHA256 3cf6ab74353954a82db3ca65ed8f9deb66f4b34beadc0ba1ad0224f17d978f3d SHA512 3838bb1bd86e45821a6793faa2afcffa0a887876e35fd36a2b21e6e6312256f94ab79026232197752c922ad51208dbc04a30c43e0bd0ab8d7945ee4fe2947999 WHIRLPOOL c8a082d4bd9c87022b0f7b5a3b59294c1d6b6d448d2057c378d61ca13289380af7b94233fc96933c2cf3c983190bf0ef88bd0c50bbd9e0ea145466b0221d8d25
diff --git a/dev-python/jupyter/jupyter-1.0.0-r1.ebuild b/dev-python/jupyter/jupyter-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..d08d186cc3f0
--- /dev/null
+++ b/dev-python/jupyter/jupyter-1.0.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter metapackage. Install all the Jupyter components in one go"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://patch-diff.githubusercontent.com/raw/jupyter/jupyter/pull/198.patch -> ${P}-file-colision.patch
+ "
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/qtconsole[${PYTHON_USEDEP}]
+ dev-python/jupyter_console[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+PDEPEND=">=dev-python/jupyter_core-4.2.0[${PYTHON_USEDEP}]"
+
+PATCHES=( "${DISTDIR}"/${P}-file-colision.patch )
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( "${S}"/docs/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jupyter/jupyter-1.0.0.ebuild b/dev-python/jupyter/jupyter-1.0.0.ebuild
new file mode 100644
index 000000000000..2d9cc0f1408f
--- /dev/null
+++ b/dev-python/jupyter/jupyter-1.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter metapackage. Install all the Jupyter components in one go"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/qtconsole[${PYTHON_USEDEP}]
+ dev-python/jupyter_console[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( "${S}"/docs/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jupyter/metadata.xml b/dev-python/jupyter/metadata.xml
new file mode 100644
index 000000000000..07ac384073dd
--- /dev/null
+++ b/dev-python/jupyter/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+Install the Jupyter system, including the notebook, qtconsole, and the IPython kernel.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">jupyter</remote-id>
+ <remote-id type="github">jupyter/jupyter</remote-id>
+ </upstream>
+</pkgmetadata>