summaryrefslogtreecommitdiff
path: root/dev-python/jupyter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/jupyter
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/jupyter')
-rw-r--r--dev-python/jupyter/Manifest5
-rw-r--r--dev-python/jupyter/jupyter-1.0.0-r1.ebuild50
-rw-r--r--dev-python/jupyter/jupyter-1.0.0.ebuild44
-rw-r--r--dev-python/jupyter/metadata.xml15
4 files changed, 0 insertions, 114 deletions
diff --git a/dev-python/jupyter/Manifest b/dev-python/jupyter/Manifest
deleted file mode 100644
index 7dd04b1bfede..000000000000
--- a/dev-python/jupyter/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-DIST jupyter-1.0.0-file-colision.patch 1727 BLAKE2B 59bf5e567e6da9e9f3d84178942993072e1697c1c4c06e06d606dce7bdc76d296d10c30cdef2865bce7b4c26136a1b0a2860f009f1530c1815b48b3300401501 SHA512 a6b4cc6b91bb9941f029963cc3e3b7f415192f64788a34dde7828d450497987f92c25655c5ca183a7408fb1fb439917ba0f0a1ef1db3fe3bec1fc46d9ad2cf4d
-DIST jupyter-1.0.0.tar.gz 12916 BLAKE2B 36476eaf0119613ba6d9f153aab1658f43951dc3879cb6a9e90d8fba14cc1247305e18fda2251127faac4e68867efd3ef57129675bbe89a17a6469255efcade2 SHA512 1f0bc83f7a127c98ccf4b3868814116aa272ea5d0baac52d7a022305af7e2da28ca2b90fa3554ff085d8df3eb6d8b8cde80bf02b8e66064c59900b926d73c520
-EBUILD jupyter-1.0.0-r1.ebuild 1302 BLAKE2B c5de62ebdabd854364285235f929d7c32b49fa5755863a8988b5972add1bc373384ce42f5ea4fa7a1f09115081c7b2415a4b3d946fdd369c5ca405d308d2cd51 SHA512 164aaa9f420731c17be819ec56cc034d7280084311da45fd56fa7cac1b979071e95a85f1a1e034b4315022473d7b0e92134cfd00fc4852ac56af3863abc194b9
-EBUILD jupyter-1.0.0.ebuild 1075 BLAKE2B 16b68c1425bd92d14bc4bab2814c369c5543b923f88b85c5cfc3d94f15172b8ae72cee74b175a24ed03a5e5ade29394a4b110d0e52a1af2aaa955dbd61bfbde6 SHA512 34ff80f3d9f05e1798c83b17e756682ed8142ca0180fba8401fddbb7d0ed3c1b57c92addaf35f81e41623fd0df3621168ab9acadf5dfce3ee7e544b9547f9797
-MISC metadata.xml 518 BLAKE2B 9698e2cc9423ef542d9cfb8b19be99b925a4098fa1350ad0806c384c495aca26852cedac070d7b83db27444413f72e201f7daac1ce30d05bffc09ac8270b2d7e SHA512 3838bb1bd86e45821a6793faa2afcffa0a887876e35fd36a2b21e6e6312256f94ab79026232197752c922ad51208dbc04a30c43e0bd0ab8d7945ee4fe2947999
diff --git a/dev-python/jupyter/jupyter-1.0.0-r1.ebuild b/dev-python/jupyter/jupyter-1.0.0-r1.ebuild
deleted file mode 100644
index 0c440411087f..000000000000
--- a/dev-python/jupyter/jupyter-1.0.0-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Jupyter metapackage. Install all the Jupyter components in one go"
-HOMEPAGE="http://jupyter.org"
-SRC_URI="
- mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
- https://patch-diff.githubusercontent.com/raw/jupyter/jupyter/pull/198.patch -> ${P}-file-colision.patch
- "
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND="
- dev-python/notebook[${PYTHON_USEDEP}]
- dev-python/qtconsole[${PYTHON_USEDEP}]
- dev-python/jupyter_console[${PYTHON_USEDEP}]
- dev-python/nbconvert[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/ipywidgets[${PYTHON_USEDEP}]"
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-PDEPEND=">=dev-python/jupyter_core-4.2.0[${PYTHON_USEDEP}]"
-
-PATCHES=( "${DISTDIR}"/${P}-file-colision.patch )
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( "${S}"/docs/build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/jupyter/jupyter-1.0.0.ebuild b/dev-python/jupyter/jupyter-1.0.0.ebuild
deleted file mode 100644
index 2d9cc0f1408f..000000000000
--- a/dev-python/jupyter/jupyter-1.0.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Jupyter metapackage. Install all the Jupyter components in one go"
-HOMEPAGE="http://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc"
-
-RDEPEND="
- dev-python/notebook[${PYTHON_USEDEP}]
- dev-python/qtconsole[${PYTHON_USEDEP}]
- dev-python/jupyter_console[${PYTHON_USEDEP}]
- dev-python/nbconvert[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/ipywidgets[${PYTHON_USEDEP}]"
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( "${S}"/docs/build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/jupyter/metadata.xml b/dev-python/jupyter/metadata.xml
deleted file mode 100644
index 07ac384073dd..000000000000
--- a/dev-python/jupyter/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription>
-Install the Jupyter system, including the notebook, qtconsole, and the IPython kernel.
- </longdescription>
- <upstream>
- <remote-id type="pypi">jupyter</remote-id>
- <remote-id type="github">jupyter/jupyter</remote-id>
- </upstream>
-</pkgmetadata>