summaryrefslogtreecommitdiff
path: root/dev-python/jupyter-ydoc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-20 10:17:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-20 10:17:50 +0100
commit399fa07bfac673a8846466b16c76549e329b55b8 (patch)
tree29af17ef91f1bd986b8e615a96b61db7fad5df14 /dev-python/jupyter-ydoc
parent388a0747e5972613060d5ca13955b5cd7132533d (diff)
gentoo auto-resync : 20:05:2023 - 10:17:50
Diffstat (limited to 'dev-python/jupyter-ydoc')
-rw-r--r--dev-python/jupyter-ydoc/Manifest4
-rw-r--r--dev-python/jupyter-ydoc/files/jupyter-ydoc-1.0.0-no-node-for-version.patch30
-rw-r--r--dev-python/jupyter-ydoc/jupyter-ydoc-1.0.0.ebuild52
-rw-r--r--dev-python/jupyter-ydoc/metadata.xml13
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-python/jupyter-ydoc/Manifest b/dev-python/jupyter-ydoc/Manifest
new file mode 100644
index 000000000000..d5659c6816c5
--- /dev/null
+++ b/dev-python/jupyter-ydoc/Manifest
@@ -0,0 +1,4 @@
+AUX jupyter-ydoc-1.0.0-no-node-for-version.patch 846 BLAKE2B 11112ffe502a4fa87abb4955f082ab6beef545a4327bb449586f1b837c78cce2cc863e7b40d71690920da6bf1346c8aa84e462cc9f16c7b51fc6a539ccea5dac SHA512 e9d82e27ce628a1e96fade29429c2532637c89cc6ad1ce307d74f493096ab003f5a9ea35247976ff6f7da8af566ef69c4cd82cec3ebd8a2a6bb72d67148b53d7
+DIST jupyter_ydoc-1.0.0.gh.tar.gz 985632 BLAKE2B 6e4456d3eb96f40e4703d7a1413d62d82497ff46fa15c3e0c6a9dd6544cdbddf5cb5b24d87e135170af643bc45b6b88a0a5f5a3fd03986d85f8428b5f12c4b85 SHA512 7cf8f37fb28ce1b0cf02e5e2db642e6fd5debbf5cb6a119b5291ea2930b177d5f17d7236e105891e828e2c0a4ced3c06cb4e78a1b6c2c318e2674fa5da2a8b8b
+EBUILD jupyter-ydoc-1.0.0.ebuild 1187 BLAKE2B 1fdda133c2390b85886ebfb7cf205b07a520a20f60ecd742c084eac7c19acb0045d7021afb3114559443c0daf8c3be41461b5104511792a5ccdab210da3d36df SHA512 c6498682fbd2269be7be7ceea2e4c889383297aaaf3d88944e53d5758492c4f4e65958d0adf7f008b6d102f4b5542e368904e645f5dc2d31bcb0cae5f66f2f49
+MISC metadata.xml 433 BLAKE2B cf2579c7d85eefe97d8ec81f37ac5e10deee9aaf52b16cea8ce3649f6076a3afee9e7ce6efbf82cd7713421353b53c16ed4d28b03a9b6e8b5c029fc6f3615651 SHA512 1258a3f0bd2a959055312594eb72bcd06fd639cf777543b41919da60b4082d241ad87231bdfb8c2ef057c85657875ac596b732301d3fb0c9a10cea5d2746234f
diff --git a/dev-python/jupyter-ydoc/files/jupyter-ydoc-1.0.0-no-node-for-version.patch b/dev-python/jupyter-ydoc/files/jupyter-ydoc-1.0.0-no-node-for-version.patch
new file mode 100644
index 000000000000..2195a0d60e0b
--- /dev/null
+++ b/dev-python/jupyter-ydoc/files/jupyter-ydoc-1.0.0-no-node-for-version.patch
@@ -0,0 +1,30 @@
+diff --git a/pyproject.toml b/pyproject.toml
+index 6e0a069..42f76c1 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -2,12 +2,12 @@
+ # Distributed under the terms of the Modified BSD License.
+
+ [build-system]
+-requires = ["hatchling>=1.10.0", "hatch-nodejs-version"]
++requires = ["hatchling>=1.10.0"]
+ build-backend = "hatchling.build"
+
+ [project]
+ name = "jupyter-ydoc"
+-dynamic = ["version"]
++version = "1.0.0"
+ description = "Document structures for collaborative editing using Ypy"
+ requires-python = ">=3.7"
+ keywords = ["jupyter", "ypy"]
+@@ -56,10 +56,6 @@ text = "BSD 3-Clause License"
+ Homepage = "https://jupyter.org"
+ Source = "https://github.com/jupyter-server/jupyter_ydoc"
+
+-[tool.hatch.version]
+-source = "nodejs"
+-path = "javascript/package.json"
+-
+ [tool.hatch.build]
+ exclude = ["javascript", "!javascript/package.json"]
+
diff --git a/dev-python/jupyter-ydoc/jupyter-ydoc-1.0.0.ebuild b/dev-python/jupyter-ydoc/jupyter-ydoc-1.0.0.ebuild
new file mode 100644
index 000000000000..bd7415f0813d
--- /dev/null
+++ b/dev-python/jupyter-ydoc/jupyter-ydoc-1.0.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Document structures for collaborative editing using Ypy"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/jupyter_ydoc/
+ https://pypi.org/project/jupyter-ydoc/
+"
+SRC_URI="
+ https://github.com/jupyter-server/jupyter_ydoc/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Requires node
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/y-py-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/y-py-0.7.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib-metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.9)
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ >=dev-python/websockets-10.0[${PYTHON_USEDEP}]
+ <dev-python/ypy-websocket-0.9.0[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-node-for-version.patch"
+)
+
+distutils_enable_tests pytest
+# Hangs for some reason
+#distutils_enable_sphinx docs/source dev-python/myst-parser dev-python/pydata-sphinx-theme
diff --git a/dev-python/jupyter-ydoc/metadata.xml b/dev-python/jupyter-ydoc/metadata.xml
new file mode 100644
index 000000000000..a7e33c55e1cf
--- /dev/null
+++ b/dev-python/jupyter-ydoc/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">jupyter-ydoc</remote-id>
+ <remote-id type="github">jupyter-server/jupyter_ydoc</remote-id>
+ </upstream>
+</pkgmetadata>