summaryrefslogtreecommitdiff
path: root/dev-python/jupyter-server
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-22 06:30:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-22 06:30:44 +0000
commit5a2cecfc8661e1d3a762adf05cf8eb142cd41710 (patch)
tree341806a72603cc8845e7e1595289e7a8b9570f2a /dev-python/jupyter-server
parentd2bcdab82e5f5f38a8ab54026e8aa94edb1b77a6 (diff)
gentoo auto-resync : 22:12:2024 - 06:30:44HEADmaster
Diffstat (limited to 'dev-python/jupyter-server')
-rw-r--r--dev-python/jupyter-server/Manifest2
-rw-r--r--dev-python/jupyter-server/jupyter-server-2.15.0.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/jupyter-server/Manifest b/dev-python/jupyter-server/Manifest
index ae2e1ffdb84e..0a6a296a6817 100644
--- a/dev-python/jupyter-server/Manifest
+++ b/dev-python/jupyter-server/Manifest
@@ -1,3 +1,5 @@
DIST jupyter_server-2.14.2.tar.gz 719933 BLAKE2B 2d8a8a283b394ceaabde14b2a997fc71d7dccc80a284ef7770d948634e48c8689c8393c77992d685abd7d8766b8608cfd279a47b5cc9569b6f6c98d416f284c8 SHA512 ea8fbf93c1bafcdb77c95cc65e2e7c6e9d010add7fb8b2b1d4538f415c4b39a89cf18a58795da05dd41a838fc1057fadde3f68d9bc73d532aec76ae5cab357a7
+DIST jupyter_server-2.15.0.tar.gz 725227 BLAKE2B da7b0106de95aa2dd3abed6d89e768a8beed1377b6a5dd0f6f9d79cd5c22cfe1259279be34771f48065ce618ae5de61ff1376a30af6c2085c481eecdec0b0d62 SHA512 96d5cf536c0ac242c86f20d0c18662f544d8d6b7a11a3fd06e473205fa597da02333f2064ffc9440ffd177c916dd37b3c608a623c35443e67663768aae97f0fc
EBUILD jupyter-server-2.14.2.ebuild 2425 BLAKE2B fc16f8ac0829c3025a1c675be434cba9aabe612cd7090549ad766a7ee425dce5e7f97093acc6c1e1a0d396d350b4716ec842058154fca4b444e2bb77ea799c7d SHA512 52ab1fb879a050a057c82f78acca2c62d47fb424d1fa24b9ed5e1ed7675abd551cdf62a7487fa3aff03ca622c6bc30d6581efd6f584993ae94c8ea0052b956e8
+EBUILD jupyter-server-2.15.0.ebuild 2524 BLAKE2B 43c58c511ed73a6aae9934df45b11dd0154f3f766968ae14c1ad063dc8f1b42f30ea7c3947e4a76a62f739d960b0a754d2fca32ee986d007557ec4fbd5cbbd2f SHA512 ac82229988276d5fb218012e12cd34433b319c0cd6f6978d965b09e401f045f4cba3e3da2865547f7e07e40d164259edc2ec62f3f496f8b5d45e0894cf9d36fb
MISC metadata.xml 544 BLAKE2B ec5a0aea1d2ad6ce0e59972d2ef4ce62c03877d464dfdc34bcb94a7d01304c63761c6bc30ed973bba1f4100e25f70541bed4eea858deb44f359d0e373ae1ade0 SHA512 ffe7deb7349ce99890b902a225b73913185bfa860237dea8c1a508a6a5e84bbb74ca7a5c43253c9986f97fb3fd1e9f2bb63ca60f73953fcc851359df8adb5fbd
diff --git a/dev-python/jupyter-server/jupyter-server-2.15.0.ebuild b/dev-python/jupyter-server/jupyter-server-2.15.0.ebuild
new file mode 100644
index 000000000000..9ba53e4f8c78
--- /dev/null
+++ b/dev-python/jupyter-server/jupyter-server-2.15.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Core services, APIs, and REST endpoints to Jupyter web applications"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/jupyter_server/
+ https://pypi.org/project/jupyter-server/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/anyio-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/argon2-cffi-21.1[${PYTHON_USEDEP}]
+ >=dev-python/jinja2-3.0.3[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-7.4.4[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-terminals-0.4.4[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-events-0.11.0[${PYTHON_USEDEP}]
+ >=dev-python/nbconvert-6.4.4[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.3.0[${PYTHON_USEDEP}]
+ >=dev-python/overrides-5.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-22.0[${PYTHON_USEDEP}]
+ >=dev-python/prometheus-client-0.9[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-24[${PYTHON_USEDEP}]
+ >=dev-python/send2trash-1.8.2[${PYTHON_USEDEP}]
+ >=dev-python/terminado-0.8.3[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.6.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-1.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-jupyter-builder[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.7[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # This fails if your terminal is zsh (and maybe other non-bash as well?)
+ tests/test_terminal.py
+ # Fails because above is ignored
+ tests/auth/test_authorizer.py
+ # Fails with additional extensions installed
+ tests/extension/test_app.py::test_stop_extension
+ )
+
+ # FIXME: tests seem to be affected by previously installed version
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest \
+ -p pytest_tornasync.plugin \
+ -p jupyter_server.pytest_plugin \
+ -p pytest_console_scripts \
+ -p pytest_timeout \
+ -p pytest_rerunfailures --reruns=5 \
+ -o tmp_path_retention_policy=all
+}