summaryrefslogtreecommitdiff
path: root/dev-python/jupyter-lsp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /dev-python/jupyter-lsp
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'dev-python/jupyter-lsp')
-rw-r--r--dev-python/jupyter-lsp/Manifest2
-rw-r--r--dev-python/jupyter-lsp/jupyter-lsp-1.5.0.ebuild46
2 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/jupyter-lsp/Manifest b/dev-python/jupyter-lsp/Manifest
index 77fa41e8ff97..64373aaad3d6 100644
--- a/dev-python/jupyter-lsp/Manifest
+++ b/dev-python/jupyter-lsp/Manifest
@@ -1,5 +1,3 @@
-DIST jupyter-lsp-1.5.0.tar.gz 35747 BLAKE2B 110840905b929c5aab420493e1535fbe5329dc5cc7204d48c59fd656b6b98ca5830887fa5eb513299cfd1ed63cda2f133652c85fe8a285ac304212598be2afbf SHA512 868b16236d02aaf055431f88f1680df9f8b8f5bf9de0feee3f378d23a653c5e7555602717bf30b7e48089e287dc595f8674f9431296a24e788c54f085e50bc79
DIST jupyter-lsp-1.5.1.tar.gz 35907 BLAKE2B bc69791253bfcf40188fe2bae24a2681ce17835f5eb1d2640edf93a69285b33d426bffdf09c66308e6f79e33c4778e539fc2a7ed056fe64758e82acc6374b4cf SHA512 585c7b3b7ea87fd9d3ad27e3e4473f3bce56ad41d3b028173e2fcad4b0d2db5b1c0c89cd8c976c3f8b4d30ae7a63018dc1e19d4527b56eafe21ec0b5e89a538b
-EBUILD jupyter-lsp-1.5.0.ebuild 1099 BLAKE2B aa1c046b5a61bb5006e9e8169e2e42eb9fd66f0f9801dc857c51518ffd26b452cd225e97e69479e2d2a56ece9ebe1060fdacd1284f8a6c2e62263040a47651c6 SHA512 62c4726535b31239ff0e70a3b00061e60e0ecb7139aae181e8b31abc9a569b01ce5c81fa670487416e20b7e9a82bfa3525d8577fa919a7330a36e727eaae50d8
EBUILD jupyter-lsp-1.5.1.ebuild 1099 BLAKE2B aa1c046b5a61bb5006e9e8169e2e42eb9fd66f0f9801dc857c51518ffd26b452cd225e97e69479e2d2a56ece9ebe1060fdacd1284f8a6c2e62263040a47651c6 SHA512 62c4726535b31239ff0e70a3b00061e60e0ecb7139aae181e8b31abc9a569b01ce5c81fa670487416e20b7e9a82bfa3525d8577fa919a7330a36e727eaae50d8
MISC metadata.xml 417 BLAKE2B 37e0faca144a5da718475df6e957d9664fa5a757735bf65985dba486180dce37621cf3c34cadef4dbefbdb5698192b601a8e0bb1c77f71ba5550e65e47cc5e9c SHA512 6b61ffc68a46993386baa1c1b95850edbfbdb8d4fa40c4111aaf4edbb7d8d4f8ed21960ee01e69e2a8b986f66c6ec4ff938392d7849e204936f05d62ce7e8531
diff --git a/dev-python/jupyter-lsp/jupyter-lsp-1.5.0.ebuild b/dev-python/jupyter-lsp/jupyter-lsp-1.5.0.ebuild
deleted file mode 100644
index 96e6e10a9283..000000000000
--- a/dev-python/jupyter-lsp/jupyter-lsp-1.5.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Multi-Language Server WebSocket proxy for Jupyter Notebook/Lab"
-HOMEPAGE="https://github.com/krassowski/jupyterlab-lsp"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-# TODO: Find out what is going on here
-# asyncio.exceptions.TimeoutError
-RESTRICT="test"
-
-RDEPEND="
- dev-python/entrypoints[${PYTHON_USEDEP}]
- >=dev-python/jupyter_server-1.1.2[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Do not depend on pytest-cov or flake8
- sed -i -e '/--cov/d' -e '/--flake8/d' setup.cfg || die
- # R lsp server not packaged
- sed -i -e 's:test_r_package_detection:_&:' \
- jupyter_lsp/tests/test_detect.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- mv "${ED}/usr/etc" "${ED}/etc" || die
-}
-
-pkg_postinst() {
- optfeature "Language server for Python" dev-python/python-lsp-server
-}