summaryrefslogtreecommitdiff
path: root/dev-python/jupyter-events
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-20 10:17:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-20 10:17:50 +0100
commit399fa07bfac673a8846466b16c76549e329b55b8 (patch)
tree29af17ef91f1bd986b8e615a96b61db7fad5df14 /dev-python/jupyter-events
parent388a0747e5972613060d5ca13955b5cd7132533d (diff)
gentoo auto-resync : 20:05:2023 - 10:17:50
Diffstat (limited to 'dev-python/jupyter-events')
-rw-r--r--dev-python/jupyter-events/Manifest5
-rw-r--r--dev-python/jupyter-events/jupyter-events-0.5.0.ebuild40
-rw-r--r--dev-python/jupyter-events/jupyter-events-0.6.3.ebuild40
-rw-r--r--dev-python/jupyter-events/metadata.xml17
4 files changed, 102 insertions, 0 deletions
diff --git a/dev-python/jupyter-events/Manifest b/dev-python/jupyter-events/Manifest
new file mode 100644
index 000000000000..b635c08b3afe
--- /dev/null
+++ b/dev-python/jupyter-events/Manifest
@@ -0,0 +1,5 @@
+DIST jupyter_events-0.5.0.tar.gz 55838 BLAKE2B a3ac815a28d2592a10394569726b76de75cb3baab0bab4c1f276da33375ba93d6bfed71fbfaca404a238b7af58ebd7e75dd7fdf6c8717141517c2f790eeb9514 SHA512 49c21f0d5dce18b137f73911b0272919a56c972561deceb228558ea369f2091ce219ac335eec002b22ca1465b2622330fb3d8973d142df4b76e350345cb6249a
+DIST jupyter_events-0.6.3.tar.gz 59393 BLAKE2B 0f747cc099e8b0e30024b7fa61007d4449fad1be3b4807021df28668969dca18087634606d6f2c453da81da9c107576133e13ec373cf34362d0182320e84e809 SHA512 a9b9c180f7b4759a3d2c99421947a837020149ec1a91ad0cd06971d7ae99ad1050652f01f78c9478ce3fd3f1a1ab6b579e90c279fcee0771546f3c346becd61f
+EBUILD jupyter-events-0.5.0.ebuild 1019 BLAKE2B 31be848e26b53dae919dbdb4e7ac5e2d28b42f35b30530f09f187ccf63eb1348ee96898f21a03c05d7f8e3ba92f50e3e38cc0580e4b659d08ac151d92e328595 SHA512 e45695af80ea00b0c152231cfbb186eb37e9eed18541cbfccf93aa543f06646d99a19ae7fc9ee8e8b630773dbfb1867f7f792cdf558368eb99e63464aada79c0
+EBUILD jupyter-events-0.6.3.ebuild 1041 BLAKE2B 01d844fddbde946ac9f33163379dbd843f5193ecc3196a2ec18b99a5cb3c29fd91e7295ad4cb6c08877a032d0c6534e685731d2ee65fa79cb665c27b4dc23096 SHA512 440795c72fb2e1bf9a5e2412d06b2f1ed3c03187e599b7d9aff7f6bfd1ef3e653d10faf6e910020506665beb8d03fb0f85493e2d0da61cb5c0269744c805c8cf
+MISC metadata.xml 537 BLAKE2B dfe33b67ac51a46c9ad33d4b0e02ff39d5aa1780d70f92f12b7ee8ac336c43caa79201bebd42c461373bfdc7608580487ec000613cf92765fec352b70a8aec13 SHA512 689e8a1125b4da96db6d6c4495933ee29d24666ad9e7e3af891170f8da512ac388c005836402c74418476cb9838f278c19f5267840533cef0e02091d47fa43ea
diff --git a/dev-python/jupyter-events/jupyter-events-0.5.0.ebuild b/dev-python/jupyter-events/jupyter-events-0.5.0.ebuild
new file mode 100644
index 000000000000..aa7f35f09849
--- /dev/null
+++ b/dev-python/jupyter-events/jupyter-events-0.5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter Event System library"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_events/
+ https://pypi.org/project/jupyter-events/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+# jsonschema[format-nongpl] deps are always on in our ebuild
+RDEPEND="
+ >=dev-python/jsonschema-4.3.0[${PYTHON_USEDEP}]
+ >=dev-python/python-json-logger-2.0.4[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+# TODO: package jupyterlite-sphinx
+# distutils_enable_sphinx docs
+distutils_enable_tests pytest
diff --git a/dev-python/jupyter-events/jupyter-events-0.6.3.ebuild b/dev-python/jupyter-events/jupyter-events-0.6.3.ebuild
new file mode 100644
index 000000000000..01ada11cc180
--- /dev/null
+++ b/dev-python/jupyter-events/jupyter-events-0.6.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter Event System library"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_events/
+ https://pypi.org/project/jupyter-events/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+# jsonschema[format-nongpl] deps are always on in our ebuild
+RDEPEND="
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-json-logger-2.0.4[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+# TODO: package jupyterlite-sphinx
+# distutils_enable_sphinx docs
+distutils_enable_tests pytest
diff --git a/dev-python/jupyter-events/metadata.xml b/dev-python/jupyter-events/metadata.xml
new file mode 100644
index 000000000000..0b3c9998d541
--- /dev/null
+++ b/dev-python/jupyter-events/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">jupyter-events</remote-id>
+ <remote-id type="github">jupyter/jupyter_events</remote-id>
+ </upstream>
+</pkgmetadata>