summaryrefslogtreecommitdiff
path: root/dev-python/jupyter-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-05 11:25:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-05 11:25:00 +0100
commitad77dc19e91d2c023f80e11e8974536d80e3a743 (patch)
tree42bb312ab0eb61fd94103e3eddb65b134f6be5a4 /dev-python/jupyter-core
parent6de28447d66e6c47ee682740b840cdb67244d4b1 (diff)
gentoo auto-resync : 05:04:2023 - 11:25:00
Diffstat (limited to 'dev-python/jupyter-core')
-rw-r--r--dev-python/jupyter-core/Manifest3
-rw-r--r--dev-python/jupyter-core/jupyter-core-5.3.0.ebuild38
-rw-r--r--dev-python/jupyter-core/metadata.xml22
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/jupyter-core/Manifest b/dev-python/jupyter-core/Manifest
new file mode 100644
index 000000000000..629791ddf8f0
--- /dev/null
+++ b/dev-python/jupyter-core/Manifest
@@ -0,0 +1,3 @@
+DIST jupyter_core-5.3.0.tar.gz 83909 BLAKE2B c0e5418770a4d3527e825bcd63cb9371855f544f19493b82f49db892fc92e91fd257b07b45d7cf20760f9ac9205346b3ec533491baf45f225764e6d310524bb8 SHA512 2c63f59a9618ee01d200e233cf85d586d88976c8d545235be224f9c64a54eb3a70e8b47220cc29b8ad3c102cc6c8754c8ccff2a771899986f322def5f539e072
+EBUILD jupyter-core-5.3.0.ebuild 889 BLAKE2B 57882e4d559e174656e6d711f83c8f8ad1b2cf2bd2b883bfbf8554ec03b890b1cc3a36bcd2091d327ef5e12a539c32e2671d753ed68e99311f19f1bfe52d6b09 SHA512 cbee64eda3826a167f0663f122e560dfe465a8a173e8dfa636f6368713b509ae79eda308d889a6db2753d7db0570dc6f083a69c7b2d4bc377da80f6a1324b75d
+MISC metadata.xml 759 BLAKE2B 4ef6a95640943d1b082bb65ae17515300089c6d78c0aa81410f4c7e57e1447787ad15373f314f8ea5c980459f4e5f74ee54edace2eb9421991e2425793040adc SHA512 d9769460a005d11961ebabc81636065aec545166820e923ab7abd58782e0832592a58611ccb4485164ef7c1c646812e8f608fafb9639525663732dec730542f5
diff --git a/dev-python/jupyter-core/jupyter-core-5.3.0.ebuild b/dev-python/jupyter-core/jupyter-core-5.3.0.ebuild
new file mode 100644
index 000000000000..5d6b232808dc
--- /dev/null
+++ b/dev-python/jupyter-core/jupyter-core-5.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_core/
+ https://pypi.org/project/jupyter-core/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ >=dev-python/platformdirs-2.5[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-autodoc-typehints \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinxcontrib-spelling \
+ dev-python/traitlets
+distutils_enable_tests pytest
diff --git a/dev-python/jupyter-core/metadata.xml b/dev-python/jupyter-core/metadata.xml
new file mode 100644
index 000000000000..f110b0a5181c
--- /dev/null
+++ b/dev-python/jupyter-core/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ Core common functionality of Jupyter projects.
+ This package contains base application classes and configuration
+ inhertited by other projects. It doesn't do much on its own.
+ </longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">jupyter-core</remote-id>
+ <remote-id type="github">jupyter/jupyter_core</remote-id>
+ </upstream>
+</pkgmetadata>