summaryrefslogtreecommitdiff
path: root/dev-python/jupyter-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-30 10:08:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-30 10:08:01 +0100
commit97b6af3d234a8e2f0a40851cb5701b3172cdbf63 (patch)
tree46170bc4077ce9e1435c4e80ae2e0d6185e3190c /dev-python/jupyter-client
parent4c2ed878d2353b3decc88b86f66017cdee3ceeeb (diff)
gentoo auto-resync : 30:08:2023 - 10:08:01
Diffstat (limited to 'dev-python/jupyter-client')
-rw-r--r--dev-python/jupyter-client/Manifest2
-rw-r--r--dev-python/jupyter-client/jupyter-client-8.3.1.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/jupyter-client/Manifest b/dev-python/jupyter-client/Manifest
index d6d9b7e2c0d2..741cd9facbc9 100644
--- a/dev-python/jupyter-client/Manifest
+++ b/dev-python/jupyter-client/Manifest
@@ -1,3 +1,5 @@
DIST jupyter_client-8.3.0.tar.gz 335973 BLAKE2B dd4b60994f5c2ba19d41f87dbbee1291e85595908e5b1fce77876d8164bc21bd65b257a65b333e2e3277fff66869d445fcd87c3c1a16166fa71da24d26b1e96e SHA512 2348cf67344cb9bbb9b020ef5570f5ca354c8acb00b9fb0d148b9419ec2efb922b1364ed3c2c2429ad66548af5dd90f232be1d56728ef09bd833312f13c07f77
+DIST jupyter_client-8.3.1.tar.gz 337007 BLAKE2B fdb0535ccda1ca13e2ead09c6df9f30c8c7d258dbfa4882a758b3923fd5bdf6afa80859f941bcc3e1a602de31c6ceef06b7a5d360d64ceab34e40de65dc65174 SHA512 ce600985ed9d36d4a96bbed6142b46988d46ea468d8f266fd3c9a7357f60d5e2a9bddb11c912a3c137079322e4363b975c4b43b1a53e65b5d649d367a098a52d
EBUILD jupyter-client-8.3.0.ebuild 1326 BLAKE2B 64579f9923761f42a5c0a546b8b90cf3c12075956eab84968c47fa851443553799f3bd33078de252990b4c3665477b97a77a74957a99177729f3df3d0dbc7f3c SHA512 77d6db275a4bcf909c0f524cb966541d3c871b805fc63d61bb88d905b6db5603aa202a965847527b677845eecc2a219b7d35bdd8985fe61548a2fbf40c2f8e22
+EBUILD jupyter-client-8.3.1.ebuild 1334 BLAKE2B 683388fd55eafc26e6c60fdf1c963da29804bc1fd0716d5ca2de48fed2193693dcb9eb285b3029e9fde2ec1b7485b2f7477ebf6765a601c6681076ef7fb8c639 SHA512 966f2fbe3436dadd32036c366e63891fb8bd48ca9d636317c2598c9ec3ca32a2ea4048d0722703333cdc604efd9352eb14a38edcf56bd28d564a43e564f5a68f
MISC metadata.xml 844 BLAKE2B 8beea01f144f8e28b58b1bd4d0d2a32eda4b5e50e479c83ed940cd6894d581aa22418bc2733910465cb6980134c3a29b63a6e31f595d037b9492337285837ac6 SHA512 73f427cc561e728c6f941052a4b6f9c6ec5c9d6ba3bb601bc58313687dfc8d6ed3602e1fb2f7f0ea00aec4360c8c1200334675917d22092ed79585b117865ebd
diff --git a/dev-python/jupyter-client/jupyter-client-8.3.1.ebuild b/dev-python/jupyter-client/jupyter-client-8.3.1.ebuild
new file mode 100644
index 000000000000..13fe78be87b6
--- /dev/null
+++ b/dev-python/jupyter-client/jupyter-client-8.3.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_client/
+ https://pypi.org/project/jupyter-client/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/jupyter-core-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib-metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.{8,9})
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.4.1[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO: times out
+ tests/test_client.py::TestAsyncKernelClient::test_input_request
+ # TODO
+ tests/test_multikernelmanager.py::TestKernelManager::test_tcp_cinfo
+)