summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/jsonschema
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/jsonschema')
-rw-r--r--dev-python/jsonschema/Manifest3
-rw-r--r--dev-python/jsonschema/jsonschema-4.4.0-r2.ebuild50
-rw-r--r--dev-python/jsonschema/metadata.xml2
3 files changed, 53 insertions, 2 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
index b6e9ccf70144..10fd0c7ca352 100644
--- a/dev-python/jsonschema/Manifest
+++ b/dev-python/jsonschema/Manifest
@@ -1,3 +1,4 @@
DIST jsonschema-4.4.0.tar.gz 313519 BLAKE2B 6339c4ac9e99b55e41c133861baacb6644e04d15e915d3199955512530c946973ca6d5348746688660ea7392d53102754dba3f3380fc8aa3a4ab284a9dcde684 SHA512 8e5c138f4debf7540e2cd131f3f208d1778927ac9036f5fa67bcf5db8c62fe1bb454c7818ee61acef64e856ea4b498ef6ab08be314a3c6b1e461e0bb44db41c7
EBUILD jsonschema-4.4.0-r1.ebuild 1406 BLAKE2B e814d987746c27b388942acf0abfc55028aa5a4bb27bd4e6a6482e8b3fc31bd01c71316cec2c6552246d2c8fa119b41a13dd32c686fd70dd664cfa425f468c88 SHA512 da2f8ee25cc403494e713832cc5b1b7a187ec41589c868c5ca763d2ffc368e92a61d3136986e0a2e5132b0139bb59195e1dc27649b9075730ffc59b3e9b2ae50
-MISC metadata.xml 692 BLAKE2B 16ae14e9b64feca61846e85fc4b7346bcd19e0264fb04fbba4e14aaeb391d43ad230bd148486936744248b1b49627c775dd3b56afbfedb2b6b3b1d8465c8aa4c SHA512 dc301a6bbebb6c0b131db43dfb6c7de88decb1c362ef0097cfea617eeed7935dcf5d5be5a1e8bdf74d60910f2733e45f15805e2a98d8e8693117df9af64ee9e6
+EBUILD jsonschema-4.4.0-r2.ebuild 1380 BLAKE2B 5f69bcff8f627f459bdf133ba1c2c5e677698062cf091ddc2249f7910f14867ccc5323147c83a4c32bbd839dbbbad9a90f8474f62df3df8d84e37bd8c08c0f79 SHA512 672022f340738db3659d9ae265b5bf9ba2157215bf8eaa9a6575d994fa0ea15d8692df47ea7cad44ea8d4ba7594de27b15d0acdbfd5e9aff4c67cf790505e1a2
+MISC metadata.xml 703 BLAKE2B 240a82a967bf7e2c200a2359dc691cbfa119fbc415f41c594c981a0da551a779b9d6afd6f8aadc7daab074579d6964455cf8bc8de36f01e986d344d1082095c5 SHA512 88cf98273ec371942846bba05ec8cc38939b1ff1a4f35e16f5764d09e67830e6f86b741ccb11ca487071eef205d193f5d0ca5ab156eb429c89d10c90778594b4
diff --git a/dev-python/jsonschema/jsonschema-4.4.0-r2.ebuild b/dev-python/jsonschema/jsonschema-4.4.0-r2.ebuild
new file mode 100644
index 000000000000..847c8ba98403
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-4.4.0-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema/
+ https://github.com/python-jsonschema/jsonschema/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/pyrsistent-0.18.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_resources-1.4.0[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+# formatter deps
+RDEPEND+="
+ dev-python/fqdn[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/isoduration[${PYTHON_USEDEP}]
+ >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3986-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ dev-python/uri_template[${PYTHON_USEDEP}]
+ >=dev-python/webcolors-1.11[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires pip, does not make much sense for the users
+ jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
+ # wtf?
+ jsonschema/tests/test_deprecations.py::TestDeprecations::test_version
+)
diff --git a/dev-python/jsonschema/metadata.xml b/dev-python/jsonschema/metadata.xml
index bb56d4b870fe..6c4a82118957 100644
--- a/dev-python/jsonschema/metadata.xml
+++ b/dev-python/jsonschema/metadata.xml
@@ -16,6 +16,6 @@ Python (supporting 2.6+ including Python 3).
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">jsonschema</remote-id>
- <remote-id type="github">Julian/jsonschema</remote-id>
+ <remote-id type="github">python-jsonschema/jsonschema</remote-id>
</upstream>
</pkgmetadata>