summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-07 10:16:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-07 10:16:30 +0100
commit2c9fab2a3468abc6862cb3115c9ff63aa266bf57 (patch)
treeb9249df06dd8229d7f334cb2e536d5c56ac81d3c /dev-python/jsonschema
parent0735b7c70f35339a20b45aee2a0a0ad80d118550 (diff)
gentoo auto-resync : 07:07:2023 - 10:16:30
Diffstat (limited to 'dev-python/jsonschema')
-rw-r--r--dev-python/jsonschema/Manifest2
-rw-r--r--dev-python/jsonschema/jsonschema-4.18.0.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
index df62c618a42a..19bf52e39ac2 100644
--- a/dev-python/jsonschema/Manifest
+++ b/dev-python/jsonschema/Manifest
@@ -1,3 +1,5 @@
DIST jsonschema-4.17.3.tar.gz 297785 BLAKE2B a0383bf5612ae50e94c95dbc1774d796b62c74a7aae3056a40edb7e042ad07fd7885e61d86220120a906a4017afe30d8ee8edbbf0cf01a6dec1f212984ff1c1e SHA512 626fc913c37d2e49e4b47c9e058aab4a96c1dc50c35d8def0b2ea0ca464dc25e3318d4fde4927c11ca38068743cd81779d5189464b821407ac1de1788bad30e2
+DIST jsonschema-4.18.0.tar.gz 315551 BLAKE2B 0f885362b6c1af6385be88770b1f332f38e270ea48c81d2ab6ab37503b007bf2d7a3419c9d435e919fea7c6f6d4b3d1c84a5fd4f196237507c9803473a879f4d SHA512 83eee5a752f14475b32405a916790f033eaeb4cc4b69625abb4915972e5832878a0aa2c51c5c782169bfef5537f3072bd41682e2752380435f7de1162e66f4c1
EBUILD jsonschema-4.17.3.ebuild 1443 BLAKE2B 0f38664621760bd0b9d3d83508de64388d7ac0f543ba5b8d81977d141e06dde0e2999d89e1469229365f6a6442dbd6867217d7988a87224977ad29070b7ad861 SHA512 015430d29397c532732cfd102bc3791ac0fe316cedb697b9a1d57f862f5446125e78af4ca41bf43facaa191fae61f1bc5adc37436d0ebaaeecd34b8c3dd0d858
+EBUILD jsonschema-4.18.0.ebuild 1493 BLAKE2B 218fb2faff1cce6f1fd51d55facf8223c17c9482126abb4033e0afe823273bcacfedc0e10b7ae8a9c429a345cb03a3476d9a67445604188b4ab4899eeba65072 SHA512 8d18e969f72b7f1c5c74a3d6a73839c11f32f6a36785339521c796e133057da10d0ca7f6f12e60f8fad561e2e0f72ace04b293bc7c6fe229984a97a0aa17880f
MISC metadata.xml 705 BLAKE2B 731159cc340e6cbb15fe5a8d374188c8df685e8f8294d19af54ca3d209beb8c273b6e901b6b7fe75401324b8512ffb7f1870aefa8d4a139d1e3b84147d993af6 SHA512 1069fb33b2cf47d3dfd5e825b23ba1efa7d764d0d23aa009db522d04bc08362f5ca646411ec405cd33152a65ea8de2ea90d3dd6d4d4bf1a947ae7943e9d4c727
diff --git a/dev-python/jsonschema/jsonschema-4.18.0.ebuild b/dev-python/jsonschema/jsonschema-4.18.0.ebuild
new file mode 100644
index 000000000000..b4ab8fb92591
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-4.18.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema/
+ https://github.com/python-jsonschema/jsonschema/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-specifications-2023.03.6[${PYTHON_USEDEP}]
+ >=dev-python/referencing-0.28.4[${PYTHON_USEDEP}]
+ >=dev-python/rpds-py-0.7.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+"
+
+# formatter deps
+RDEPEND+="
+ dev-python/fqdn[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/isoduration[${PYTHON_USEDEP}]
+ >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3986-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ dev-python/uri_template[${PYTHON_USEDEP}]
+ >=dev-python/webcolors-1.11[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires pip, does not make much sense for the users
+ jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
+ # fragile warning tests
+ jsonschema/tests/test_deprecations.py
+ # wtf?
+ jsonschema/tests/test_jsonschema_test_suite.py::test_suite_bug
+)