summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-02 09:09:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-02 09:09:19 +0000
commit1ab8c7f6ed10f981d767a0acc2f420cf86775f12 (patch)
tree44eb556f62eeb50b980ae79712fa5087c2c7e3b0 /dev-python/jsonschema
parent29badda007a3bcd85bb351f602790eb3b8922448 (diff)
gentoo auto-resync : 02:11:2022 - 09:09:18
Diffstat (limited to 'dev-python/jsonschema')
-rw-r--r--dev-python/jsonschema/Manifest2
-rw-r--r--dev-python/jsonschema/jsonschema-4.17.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
index 0d1715775c3d..b5558a8b9b00 100644
--- a/dev-python/jsonschema/Manifest
+++ b/dev-python/jsonschema/Manifest
@@ -1,3 +1,5 @@
DIST jsonschema-4.16.0.tar.gz 292399 BLAKE2B b1a78bc7dbc7cd10324638b57ebe4593afbdcbeb8d4b247aa127f41d5f6cce5e7970f5db1576e6a761357d8efe453ef514ae49f58b6624a05c4b7771daff3721 SHA512 c84abc992f410e9d558e2ce06c7172e9e2d298cff469baf8a23b1ea5b4777e6addfa757c5cc62b2e28e257721ee55e04bec0852e5f525adfa87392cbf712828f
+DIST jsonschema-4.17.0.tar.gz 293414 BLAKE2B 51910903a788c5fc0fea695f40ac26c886a88a6b97e653452d11ca9b4cbe18a24fe4c28a13705f77c16c1b2342f66ac86232f9ac7c578c94f23b725580e82b17 SHA512 a0160caea26527e5afbba48fea7f0700e8cd0bb5cbd9661501d34f5dd9857971ca3fd9982bc17f570d0b5a08eb5ecfd0e5182f78a0e0a6343621ed8360643166
EBUILD jsonschema-4.16.0.ebuild 1640 BLAKE2B 9d05c031930382ed2d4783fc7caffb79a4a633241e614c042e0e57e536a4914a1374d6e17670361e2f46869cf46d53a60573fff34558fc7401112d83fde8c4b7 SHA512 7d708318a8924405db94ae833328b5b5119c2e2d6937ae6e81a0388de04e567c64a4e3e01c1e2099deccfb80b59aa8d17ffe198704403f7c4e90676ef34f5dc2
+EBUILD jsonschema-4.17.0.ebuild 1641 BLAKE2B e03c723527f0d97b8cdbe0432687325b67378a7ec9d6241327a21ddf079fcd7e94781e0d2ea3d325cc7a8a590bfcfee553aec61ddc428a5cf2eca3d635186fd7 SHA512 ab08d62e24fee05291ef45223f7aca89556733b99f9a64840499cdf61cb624eeeb3ff7fd749ad561fc2753c6aaef4a10a6981816d468058eb0394c7d133a997c
MISC metadata.xml 705 BLAKE2B 731159cc340e6cbb15fe5a8d374188c8df685e8f8294d19af54ca3d209beb8c273b6e901b6b7fe75401324b8512ffb7f1870aefa8d4a139d1e3b84147d993af6 SHA512 1069fb33b2cf47d3dfd5e825b23ba1efa7d764d0d23aa009db522d04bc08362f5ca646411ec405cd33152a65ea8de2ea90d3dd6d4d4bf1a947ae7943e9d4c727
diff --git a/dev-python/jsonschema/jsonschema-4.17.0.ebuild b/dev-python/jsonschema/jsonschema-4.17.0.ebuild
new file mode 100644
index 000000000000..ac11d050d26a
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-4.17.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema/
+ https://github.com/python-jsonschema/jsonschema/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pyrsistent-0.18.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_resources-1.4.0[${PYTHON_USEDEP}]
+ dev-python/pkgutil_resolve_name[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+"
+
+# formatter deps
+RDEPEND+="
+ dev-python/fqdn[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/isoduration[${PYTHON_USEDEP}]
+ >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3986-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ dev-python/uri_template[${PYTHON_USEDEP}]
+ >=dev-python/webcolors-1.11[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires pip, does not make much sense for the users
+ jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
+ # fragile warning tests
+ jsonschema/tests/test_deprecations.py
+ # wtf?
+ jsonschema/tests/test_jsonschema_test_suite.py::test_suite_bug
+)