summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema-specifications
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-24 13:27:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-24 13:27:08 +0100
commitbfc2a8298cab03d289dc2cfed63308396fa0babe (patch)
tree2d4288572b0938dcfc64edd39a4c1086402931a5 /dev-python/jsonschema-specifications
parente28a6e6eb5373071be3a09aa457f0488d753c80c (diff)
gentoo auto-resync : 24:06:2023 - 13:27:08
Diffstat (limited to 'dev-python/jsonschema-specifications')
-rw-r--r--dev-python/jsonschema-specifications/Manifest2
-rw-r--r--dev-python/jsonschema-specifications/jsonschema-specifications-2023.6.1.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/jsonschema-specifications/Manifest b/dev-python/jsonschema-specifications/Manifest
index 16d91a07e265..2bb72502350c 100644
--- a/dev-python/jsonschema-specifications/Manifest
+++ b/dev-python/jsonschema-specifications/Manifest
@@ -1,3 +1,5 @@
DIST jsonschema_specifications-2023.5.2.tar.gz 12581 BLAKE2B 74029c066e3c620126ed0ed7e70a9b63c017aeab827b0187f8c8c5964c2e1ef68a83489f4646d79653c38fcec45bc001189fc09295ac1f569ed288f2dc469459 SHA512 222a70e3c1673c6f3d27f5d6561d4ba192c61a8a6f86e726939d1e29843eeca82de306a889540ab352a5c2332cf30d810db956aa5094f2a6bc6607b7169513fd
+DIST jsonschema_specifications-2023.6.1.tar.gz 12645 BLAKE2B 9dea1acae9e53a9f8ff93dd54d5df3bb1dd960036dfcc4dcc0c6287ae816c0ca60c139b35aa14901e2e9f61dca339cf9d84a5c5e8f91a62a40696db9daa1a099 SHA512 b7a0d7fdc642e08cf3515dfae6d8cbb14e4d40c3b1fe3cb6c87ee11c47a9d6ede33b28d9fe6f3d4f0ff1807469a015cd8fcacff9575a356a74b462af9681aa6c
EBUILD jsonschema-specifications-2023.5.2.ebuild 618 BLAKE2B 1e07cc9b380f661c3e6254eef681188984768c097f0a7e3336e2cac2b348ae206ec92d2534764850b91117d4cdb078f392599baff7c31214b8c6e73264a20de7 SHA512 5d96c71d00debce415811193c7acf144659236926fc1ea65a6ca655642ed709de873353de0362335f651d05af5e07dd157589fcbe9dc703463abb94f2f1b2b9d
+EBUILD jsonschema-specifications-2023.6.1.ebuild 618 BLAKE2B 1e07cc9b380f661c3e6254eef681188984768c097f0a7e3336e2cac2b348ae206ec92d2534764850b91117d4cdb078f392599baff7c31214b8c6e73264a20de7 SHA512 5d96c71d00debce415811193c7acf144659236926fc1ea65a6ca655642ed709de873353de0362335f651d05af5e07dd157589fcbe9dc703463abb94f2f1b2b9d
MISC metadata.xml 414 BLAKE2B bc0046f51a008fe67f4937f8e9eb2663c868a41fed9371301575f74fb10c38f10b21a380d865981b317189f8c25e3ef6fe18423a169cda92b1d2b1a14dab8948 SHA512 e50f0eed8995fce7e207cb5c15106f3980ebb9c3d9d0042d33c4843be231f90aa652e59e1f83335f336d9b906a38252a229c1562f25142604048497608d29794
diff --git a/dev-python/jsonschema-specifications/jsonschema-specifications-2023.6.1.ebuild b/dev-python/jsonschema-specifications/jsonschema-specifications-2023.6.1.ebuild
new file mode 100644
index 000000000000..46d56e086c48
--- /dev/null
+++ b/dev-python/jsonschema-specifications/jsonschema-specifications-2023.6.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="The JSON Schema meta-schemas and vocabularies, exposed as a Registry"
+HOMEPAGE="
+ https://github.com/python-jsonschema/jsonschema-specifications/
+ https://pypi.org/project/jsonschema-specifications/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/referencing-0.28.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest