summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema-specifications
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-15 10:39:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-15 10:39:42 +0000
commit55cd3ff92ff96fafc75066838cfc2af06df3a296 (patch)
tree80062e679cfed7bd24918ebef931ffbe5ef3e513 /dev-python/jsonschema-specifications
parent5038813910e661a4943401a80a3725aca040c01c (diff)
gentoo auto-resync : 15:11:2023 - 10:39:42
Diffstat (limited to 'dev-python/jsonschema-specifications')
-rw-r--r--dev-python/jsonschema-specifications/Manifest2
-rw-r--r--dev-python/jsonschema-specifications/jsonschema-specifications-2023.11.1.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/jsonschema-specifications/Manifest b/dev-python/jsonschema-specifications/Manifest
index 4dfc01369847..987c00081057 100644
--- a/dev-python/jsonschema-specifications/Manifest
+++ b/dev-python/jsonschema-specifications/Manifest
@@ -1,3 +1,5 @@
+DIST jsonschema_specifications-2023.11.1.tar.gz 12935 BLAKE2B 317c6c937f0939ec59e25f2d84a6eea30ae4d8f14c4787e282dc9d6d4b74d84ab4985fde8f78f0cffa0fc61efe44493afe9d79182f4c02b0d6caff18f15dfd08 SHA512 a917226f5341c2a8913fa87a9640e1a5fdb34c857a8be1a0618db15cd09de0d45e82b294f759177de5fbe002f1ad9a04196c1c0976cc99ec685764b30e648b8d
DIST jsonschema_specifications-2023.7.1.tar.gz 12689 BLAKE2B 421b0e94161c84c658a9af1ddef74fb98ca18332a2977e1ca983b04995bc0a65b3399edd4a2a52c741a4ffdbeeb4a0796371448f283ba328c72c1899f3f0b55a SHA512 78275fe6595151c611baeeebc17f08287f50a3636c3de515abfe8dc45075136874740dfa169aa3ebda004b5ead66ba93bc22b963ded14e4aa906e4b454356f7c
+EBUILD jsonschema-specifications-2023.11.1.ebuild 667 BLAKE2B c407d3077a9b80d4eca3262f99290212d047216f9327dbc83502d88c2e8e31b7b3a25b900275c0a365e4daeb3e1e838add5bf53bff56a6862551c901a394520c SHA512 031e7704c3a5f289956e7ee1ee9729e58f407b9997f118362994c779b55c64a04af7ae9a2311c4f6abd80b7f1e8c3570adb4975e2b5c0bd5773435e68596844e
EBUILD jsonschema-specifications-2023.7.1.ebuild 660 BLAKE2B e500e23d108ee01b93a40ac00287a6684671ea6604125f2003af7aa9fa8863478e4ff970069ae3ce876c444d92ada7d60369b798f47c38f943f8f276fb691f09 SHA512 704a07112e3c91aa3cea36621c10eac26627044098acb210090ec1343c85e16bf3382af19d3d02ad7f4e40d9236c70d6d8654e95e807e4ba939e2983fc0f8dbd
MISC metadata.xml 414 BLAKE2B bc0046f51a008fe67f4937f8e9eb2663c868a41fed9371301575f74fb10c38f10b21a380d865981b317189f8c25e3ef6fe18423a169cda92b1d2b1a14dab8948 SHA512 e50f0eed8995fce7e207cb5c15106f3980ebb9c3d9d0042d33c4843be231f90aa652e59e1f83335f336d9b906a38252a229c1562f25142604048497608d29794
diff --git a/dev-python/jsonschema-specifications/jsonschema-specifications-2023.11.1.ebuild b/dev-python/jsonschema-specifications/jsonschema-specifications-2023.11.1.ebuild
new file mode 100644
index 000000000000..e6366d1acc50
--- /dev/null
+++ b/dev-python/jsonschema-specifications/jsonschema-specifications-2023.11.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="The JSON Schema meta-schemas and vocabularies, exposed as a Registry"
+HOMEPAGE="
+ https://github.com/python-jsonschema/jsonschema-specifications/
+ https://pypi.org/project/jsonschema-specifications/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/referencing-0.31.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest