summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema-specifications
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-01 11:06:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-01 11:06:48 +0000
commit511da2e8215301136bf13531af2329e9703addaf (patch)
treee5b21768118114c1882a1f772d0565fb3ba1801a /dev-python/jsonschema-specifications
parentd095cf23cccb27f0f047472717fdf96bf857110d (diff)
gentoo auto-resync : 01:12:2023 - 11:06:48
Diffstat (limited to 'dev-python/jsonschema-specifications')
-rw-r--r--dev-python/jsonschema-specifications/Manifest2
-rw-r--r--dev-python/jsonschema-specifications/jsonschema-specifications-2023.11.2.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/jsonschema-specifications/Manifest b/dev-python/jsonschema-specifications/Manifest
index d2e0e159cdee..a7f6db1d22ce 100644
--- a/dev-python/jsonschema-specifications/Manifest
+++ b/dev-python/jsonschema-specifications/Manifest
@@ -1,3 +1,5 @@
DIST jsonschema_specifications-2023.11.1.tar.gz 12935 BLAKE2B 317c6c937f0939ec59e25f2d84a6eea30ae4d8f14c4787e282dc9d6d4b74d84ab4985fde8f78f0cffa0fc61efe44493afe9d79182f4c02b0d6caff18f15dfd08 SHA512 a917226f5341c2a8913fa87a9640e1a5fdb34c857a8be1a0618db15cd09de0d45e82b294f759177de5fbe002f1ad9a04196c1c0976cc99ec685764b30e648b8d
+DIST jsonschema_specifications-2023.11.2.tar.gz 13033 BLAKE2B a9e64f1956a80f040eb300b772e10c7f75ed36502b69899bcadaef79086bc209d63b139bfe94cc3f30ee250bd50b9e0021e3c7616cecd08b322160cadba69046 SHA512 de990c8e6976a2a5915f9b5882f4b9da1cbe8c63a9de70aff74efeb2c659f041815186c6cb38ca9df14fefc211cae2b3c7c8af838fc4b9b853b07f7a5362f181
EBUILD jsonschema-specifications-2023.11.1.ebuild 666 BLAKE2B 9069990ff2eccb89e423aa1e5be982593f9d0de1b2d5fa34e9ee091fde134eca05740b58cf8abd2b411a986a42d4b5872d176062adbe7b1a2280092919bfd6f7 SHA512 ebc07b1f1aac13c4e674345e7f2a8eacb3e53f93ba64507fbe9142ad2f3fcc94e0e7e4a3aa34acda546412d68b46bc71115512f62f4a48bb410cea396c7b66a0
+EBUILD jsonschema-specifications-2023.11.2.ebuild 673 BLAKE2B a133fc7ecc442dbe013eb0958cc96df508a833d9fb7ac2817d0df511f7e08163cd8bdffe66d3d7b7a0d911b563abc48fd8101c1f0fa04d620f8785f72ff79f7d SHA512 182458e4b21f72ea62a19677ac243ee578ff95aa07277b502f4ab4498c6e30818666be2d59b346f438edcdb07049825d01ee45ed24bee7fc0a79e9e9b625d041
MISC metadata.xml 414 BLAKE2B bc0046f51a008fe67f4937f8e9eb2663c868a41fed9371301575f74fb10c38f10b21a380d865981b317189f8c25e3ef6fe18423a169cda92b1d2b1a14dab8948 SHA512 e50f0eed8995fce7e207cb5c15106f3980ebb9c3d9d0042d33c4843be231f90aa652e59e1f83335f336d9b906a38252a229c1562f25142604048497608d29794
diff --git a/dev-python/jsonschema-specifications/jsonschema-specifications-2023.11.2.ebuild b/dev-python/jsonschema-specifications/jsonschema-specifications-2023.11.2.ebuild
new file mode 100644
index 000000000000..9c3a40e4cef7
--- /dev/null
+++ b/dev-python/jsonschema-specifications/jsonschema-specifications-2023.11.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="The JSON Schema meta-schemas and vocabularies, exposed as a Registry"
+HOMEPAGE="
+ https://github.com/python-jsonschema/jsonschema-specifications/
+ https://pypi.org/project/jsonschema-specifications/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/referencing-0.31.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest