summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema-specifications
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-10 04:03:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-10 04:03:58 +0100
commit3aae425b3c39d02e2dc917db0fae8c225c158ca1 (patch)
tree89f296451fba2217a7c18592ecb1762a920dead7 /dev-python/jsonschema-specifications
parent6ee17dd82a3bcd0e90af4ebfbb3e411d342761be (diff)
gentoo auto-resync : 10:10:2024 - 04:03:57
Diffstat (limited to 'dev-python/jsonschema-specifications')
-rw-r--r--dev-python/jsonschema-specifications/Manifest2
-rw-r--r--dev-python/jsonschema-specifications/jsonschema-specifications-2024.10.1.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/jsonschema-specifications/Manifest b/dev-python/jsonschema-specifications/Manifest
index b2ef53a6ebbe..49e11fa9ede0 100644
--- a/dev-python/jsonschema-specifications/Manifest
+++ b/dev-python/jsonschema-specifications/Manifest
@@ -1,3 +1,5 @@
DIST jsonschema_specifications-2023.12.1.tar.gz 13983 BLAKE2B db3cad7a900b114eff4827b6653da9e88b80cedae8f724fe030f373d98c7771f427a9960fa47cbe4d4b677805385a059aca08665271659b3e5ab43719c9d74d1 SHA512 7027641c65a6f7c618fd8c3b91af10bc45604966b6cf50780ca72c31f2135ec9d8b14de35049b4897586ad651b65392bb650d162f3bb546c9d250a8cd257ad30
+DIST jsonschema_specifications-2024.10.1.tar.gz 15561 BLAKE2B 3587ca9c5525f3a8bf91c7e0619fda6d052ec89e11acce0a1aa5c7962fb1b89d54c952d81a5116f596aabfe769c8e9ae687821929d5bf1ad76346b480b2cd2fb SHA512 333efbd81ad787da841fe8526257b4213bff508c91a6a655f2dbe62b22a0347ac8f97230b52e00aabcf626e91026a6c2f5760d54c2078eccd2f033a8599e7484
EBUILD jsonschema-specifications-2023.12.1.ebuild 671 BLAKE2B 19b228481c8f5fb8b66f0a4671c94c1558d3af81d9163229fc3637908028ee30e91e63513b7363c2a7f5778c86e91baa8da83746d6c52a9f5ea5a1eee153ccf0 SHA512 e2c6aca663f4b9462d7c6e6f9cdd3c3fe64ce00c5d76db002c937bf32cc3d099cfe00041f4ddc87580f84e96059e276fb2e588a4aa192a3ac2a1e13930defc22
+EBUILD jsonschema-specifications-2024.10.1.ebuild 678 BLAKE2B 53b378f0c9e689aafe482d8b1b78838522035c5bac83f55bf3da82a703d3aa0eaf0fb5f8346bba08009e010a0d47e55d7ca42ae6ca5416109a72a6c46643d689 SHA512 85986964d1851e29ea478425eab0d65b3d80cf0603bb9b5d6311d1cabff77483bd13b1ef67823d130914008f746f6693fc8e9e620643c609640b60f974b8d5fc
MISC metadata.xml 414 BLAKE2B bc0046f51a008fe67f4937f8e9eb2663c868a41fed9371301575f74fb10c38f10b21a380d865981b317189f8c25e3ef6fe18423a169cda92b1d2b1a14dab8948 SHA512 e50f0eed8995fce7e207cb5c15106f3980ebb9c3d9d0042d33c4843be231f90aa652e59e1f83335f336d9b906a38252a229c1562f25142604048497608d29794
diff --git a/dev-python/jsonschema-specifications/jsonschema-specifications-2024.10.1.ebuild b/dev-python/jsonschema-specifications/jsonschema-specifications-2024.10.1.ebuild
new file mode 100644
index 000000000000..049d7a5b7174
--- /dev/null
+++ b/dev-python/jsonschema-specifications/jsonschema-specifications-2024.10.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="The JSON Schema meta-schemas and vocabularies, exposed as a Registry"
+HOMEPAGE="
+ https://github.com/python-jsonschema/jsonschema-specifications/
+ https://pypi.org/project/jsonschema-specifications/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/referencing-0.31.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest