summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema-specifications
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-26 07:37:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-26 07:37:53 +0000
commit058e62d5e60f6fc7f010f73f4c1546e979344a0b (patch)
treed4cc27f68681c52e6387b26f0f9daf36979ab36b /dev-python/jsonschema-specifications
parent15bb7733ddb1f16a0e3936969282ecc42419829a (diff)
gentoo auto-resync : 26:12:2023 - 07:37:53
Diffstat (limited to 'dev-python/jsonschema-specifications')
-rw-r--r--dev-python/jsonschema-specifications/Manifest2
-rw-r--r--dev-python/jsonschema-specifications/jsonschema-specifications-2023.12.1.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/jsonschema-specifications/Manifest b/dev-python/jsonschema-specifications/Manifest
index 60b8aa7905a5..c3de44f6fabd 100644
--- a/dev-python/jsonschema-specifications/Manifest
+++ b/dev-python/jsonschema-specifications/Manifest
@@ -1,3 +1,5 @@
DIST jsonschema_specifications-2023.11.2.tar.gz 13033 BLAKE2B a9e64f1956a80f040eb300b772e10c7f75ed36502b69899bcadaef79086bc209d63b139bfe94cc3f30ee250bd50b9e0021e3c7616cecd08b322160cadba69046 SHA512 de990c8e6976a2a5915f9b5882f4b9da1cbe8c63a9de70aff74efeb2c659f041815186c6cb38ca9df14fefc211cae2b3c7c8af838fc4b9b853b07f7a5362f181
+DIST jsonschema_specifications-2023.12.1.tar.gz 13983 BLAKE2B db3cad7a900b114eff4827b6653da9e88b80cedae8f724fe030f373d98c7771f427a9960fa47cbe4d4b677805385a059aca08665271659b3e5ab43719c9d74d1 SHA512 7027641c65a6f7c618fd8c3b91af10bc45604966b6cf50780ca72c31f2135ec9d8b14de35049b4897586ad651b65392bb650d162f3bb546c9d250a8cd257ad30
EBUILD jsonschema-specifications-2023.11.2.ebuild 666 BLAKE2B 9069990ff2eccb89e423aa1e5be982593f9d0de1b2d5fa34e9ee091fde134eca05740b58cf8abd2b411a986a42d4b5872d176062adbe7b1a2280092919bfd6f7 SHA512 ebc07b1f1aac13c4e674345e7f2a8eacb3e53f93ba64507fbe9142ad2f3fcc94e0e7e4a3aa34acda546412d68b46bc71115512f62f4a48bb410cea396c7b66a0
+EBUILD jsonschema-specifications-2023.12.1.ebuild 673 BLAKE2B a133fc7ecc442dbe013eb0958cc96df508a833d9fb7ac2817d0df511f7e08163cd8bdffe66d3d7b7a0d911b563abc48fd8101c1f0fa04d620f8785f72ff79f7d SHA512 182458e4b21f72ea62a19677ac243ee578ff95aa07277b502f4ab4498c6e30818666be2d59b346f438edcdb07049825d01ee45ed24bee7fc0a79e9e9b625d041
MISC metadata.xml 414 BLAKE2B bc0046f51a008fe67f4937f8e9eb2663c868a41fed9371301575f74fb10c38f10b21a380d865981b317189f8c25e3ef6fe18423a169cda92b1d2b1a14dab8948 SHA512 e50f0eed8995fce7e207cb5c15106f3980ebb9c3d9d0042d33c4843be231f90aa652e59e1f83335f336d9b906a38252a229c1562f25142604048497608d29794
diff --git a/dev-python/jsonschema-specifications/jsonschema-specifications-2023.12.1.ebuild b/dev-python/jsonschema-specifications/jsonschema-specifications-2023.12.1.ebuild
new file mode 100644
index 000000000000..9c3a40e4cef7
--- /dev/null
+++ b/dev-python/jsonschema-specifications/jsonschema-specifications-2023.12.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="The JSON Schema meta-schemas and vocabularies, exposed as a Registry"
+HOMEPAGE="
+ https://github.com/python-jsonschema/jsonschema-specifications/
+ https://pypi.org/project/jsonschema-specifications/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/referencing-0.31.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest