summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema-spec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-02 22:17:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-02 22:17:13 +0100
commitec321939a77843497c860196ea06d7776d94b755 (patch)
tree426c3b59f57bfb684b461e65c4416048b369b4ce /dev-python/jsonschema-spec
parent2982504d287f7f91eade76902f11e691f8181071 (diff)
gentoo auto-resync : 02:09:2022 - 22:17:13
Diffstat (limited to 'dev-python/jsonschema-spec')
-rw-r--r--dev-python/jsonschema-spec/Manifest3
-rw-r--r--dev-python/jsonschema-spec/jsonschema-spec-0.1.1.ebuild36
-rw-r--r--dev-python/jsonschema-spec/metadata.xml13
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/jsonschema-spec/Manifest b/dev-python/jsonschema-spec/Manifest
new file mode 100644
index 000000000000..37a5ca87ea73
--- /dev/null
+++ b/dev-python/jsonschema-spec/Manifest
@@ -0,0 +1,3 @@
+DIST jsonschema-spec-0.1.1.gh.tar.gz 21747 BLAKE2B 441f34c62da2d22699379035e20f2ed78a974413ea9c2f80b753cc2b41d978351c69aaa50750139e622d075c4c3979dc43b888bea111a0f4b31fa9d37822a1fa SHA512 b1bdd03c6fc022877d0801d859abe0dd19e066afe2a1eab6c650a8741a50473e74945ddde429508e5dccf379a84b25fbd60c49fdc310aa770bed52b63e60e397
+EBUILD jsonschema-spec-0.1.1.ebuild 814 BLAKE2B efd6866f2a207e81882ceae0e15988228f50b82321eec183355dec8ba422530657a1d5df4f77a7c5a66ebf9fe63d22a815081e22b00c68bf0558d67f0852c5b6 SHA512 4080d1319e91bbc91a13bb86d2e3cc2d19628ee43cd9562c948a482f7278523572cee53669799ea1b5b0b6bafcb69e5ecdbaf34046b54b891b0eef804730cbb4
+MISC metadata.xml 404 BLAKE2B 2e76fe1eb441114cff26e2e60d36d2d38da053ca524a29f568d2b4af325021ab560545da43cdd0d5d3404e73ebcdb9b534da0b7de52c2acee5d3f2ed6511ee4e SHA512 58238e60fc20d210167afe2abcfdbbd826a693b5d587953437294c2c0e1ea9161486e2c583d29a7e2a0c8343e70e7688213ed011eacd155c53e232b336986701
diff --git a/dev-python/jsonschema-spec/jsonschema-spec-0.1.1.ebuild b/dev-python/jsonschema-spec/jsonschema-spec-0.1.1.ebuild
new file mode 100644
index 000000000000..da68f98a2c04
--- /dev/null
+++ b/dev-python/jsonschema-spec/jsonschema-spec-0.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="JSONSchema Spec with object-oriented paths"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema-spec/
+ https://github.com/p1c2u/jsonschema-spec
+"
+SRC_URI="
+ https://github.com/p1c2u/jsonschema-spec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv"
+
+RDEPEND="
+ >=dev-python/jsonschema-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pathable[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ dev-python/pathable[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/--cov/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/jsonschema-spec/metadata.xml b/dev-python/jsonschema-spec/metadata.xml
new file mode 100644
index 000000000000..1559254c1a65
--- /dev/null
+++ b/dev-python/jsonschema-spec/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">jsonschema-spec</remote-id>
+ <remote-id type="github">p1c2u/jsonschema-spec</remote-id>
+ </upstream>
+</pkgmetadata>