summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema-spec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-01 15:05:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-01 15:05:02 +0000
commite523ebcd50638ebe53f8f425d126bfa7385703b5 (patch)
treea8202f9224bd577afe09c919786f8836cf4a2a7c /dev-python/jsonschema-spec
parentd88834e7a12432c4e2d04ca7e938a66e25811f89 (diff)
gentoo auto-resync : 01:02:2023 - 15:05:01
Diffstat (limited to 'dev-python/jsonschema-spec')
-rw-r--r--dev-python/jsonschema-spec/Manifest2
-rw-r--r--dev-python/jsonschema-spec/jsonschema-spec-0.1.3.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/jsonschema-spec/Manifest b/dev-python/jsonschema-spec/Manifest
index 760ac667a721..661d4a3f0442 100644
--- a/dev-python/jsonschema-spec/Manifest
+++ b/dev-python/jsonschema-spec/Manifest
@@ -1,3 +1,5 @@
DIST jsonschema-spec-0.1.2.gh.tar.gz 21782 BLAKE2B 238f035e75ec45edade5fd00269d2fc208a73208d1e07586490728b8c97819d6fddd9b909d2af00e63ebc4c141cb8dbaaf8e3e7ce88c3ff58ada2ba147c1e2c9 SHA512 0cba83a14e88d4fe2fcce9e4d39fa4284f23366a1f8acab16fa4b7b824d0c02bf04429d61c51a39a7a188c4e2b79f4481bba14ca688edee71beb0060e16617e0
+DIST jsonschema-spec-0.1.3.gh.tar.gz 30794 BLAKE2B 545eda0aef433eb62cd02bbcc4d07469b26c477bbf572d71bcb4eb126acc5ab912f5f80c0699305b37f7f526f36910bcb019d66a763e679846bb20a5b01eb813 SHA512 95465c43b842289ed28dd78ec06614d77b2bbf7d9d69e5dc4b89008740d0cc85e5b3319acd66d0142b533425e8f150c4edbbf15b7f8e3bdefb28b81193a13432
EBUILD jsonschema-spec-0.1.2.ebuild 836 BLAKE2B b7c5875215dd69aa6f229e962675b2d8554d432efbc0f4e4423a26d78862f2958320b7f12cd3fe370a3b2759d3abc2a6cd5995ef380f0a2f719aa2f15ee6cdf0 SHA512 7dbc5cb7e06453c222c54674c92378cc52ef4d8d44e1e48c4b912f84f4ee2ed19b64bcfe8e5b880ad584fc9273fe1da557040c315c14c13a9c3f407306d1aefb
+EBUILD jsonschema-spec-0.1.3.ebuild 838 BLAKE2B 188cb7e9ad32e6832e62ead47f06e6522e6ef4be97edbf9d4431246a0d8e4c6d644e0065ec513abd17c1125a553b896bc9469e64c5eb7a0e6c76ef4ac0f52b8f SHA512 9bb6739314a13e637d19d00152afdac3efd5d835ddbaae77ea2efa609d9af30c8000cb33bee8f140c4c71859d3e5a9d7c7a9c71696ce22df1c77ec976e6c6a08
MISC metadata.xml 404 BLAKE2B 2e76fe1eb441114cff26e2e60d36d2d38da053ca524a29f568d2b4af325021ab560545da43cdd0d5d3404e73ebcdb9b534da0b7de52c2acee5d3f2ed6511ee4e SHA512 58238e60fc20d210167afe2abcfdbbd826a693b5d587953437294c2c0e1ea9161486e2c583d29a7e2a0c8343e70e7688213ed011eacd155c53e232b336986701
diff --git a/dev-python/jsonschema-spec/jsonschema-spec-0.1.3.ebuild b/dev-python/jsonschema-spec/jsonschema-spec-0.1.3.ebuild
new file mode 100644
index 000000000000..99f4c3f182b5
--- /dev/null
+++ b/dev-python/jsonschema-spec/jsonschema-spec-0.1.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSONSchema Spec with object-oriented paths"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema-spec/
+ https://github.com/p1c2u/jsonschema-spec/
+"
+SRC_URI="
+ https://github.com/p1c2u/jsonschema-spec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/jsonschema-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pathable[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ dev-python/pathable[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/--cov/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}