summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema-spec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-11 14:17:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-11 14:17:10 +0100
commit5adfd733728a4f14df5665f4c2a604a7356e5f19 (patch)
treef2938c4a08576b45508b02481edfec55eac3ac8b /dev-python/jsonschema-spec
parentfbba40085f5d1591a67b49f5aa48b4071b7560f1 (diff)
gentoo auto-resync : 11:06:2023 - 14:17:09
Diffstat (limited to 'dev-python/jsonschema-spec')
-rw-r--r--dev-python/jsonschema-spec/Manifest2
-rw-r--r--dev-python/jsonschema-spec/jsonschema-spec-0.1.5.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/jsonschema-spec/Manifest b/dev-python/jsonschema-spec/Manifest
index d770d84424af..6b65b1671ba3 100644
--- a/dev-python/jsonschema-spec/Manifest
+++ b/dev-python/jsonschema-spec/Manifest
@@ -1,3 +1,5 @@
DIST jsonschema-spec-0.1.4.gh.tar.gz 30903 BLAKE2B eae7ba8b811dfd14d9b2e33d3355bf8c98e088b1a8fa3314300dcc7edae31727cc5a01d0a06af412b8c7d59eca69ba816f6eb2683e997719fd300a3445e96cfd SHA512 6b3d1710fdd8c43a0f38d0687c95e4e70c55df964dc597e4a00abad3459610829bd90190b21c512c70d46498d98b80ecc2422eb73d7822539841ff10bc7c2c4f
+DIST jsonschema-spec-0.1.5.gh.tar.gz 36035 BLAKE2B 4e6019fb1c7f5e85a03488e00ef080798bc6e3e06999d9c9c931072c640fd74b5125882e43dca26bad1acc3bdacb06a26f2c95dff25339e3f8b785d759085a49 SHA512 c76b15a3ead9498696c80cf7a378a675194837f04cd88d81be5213a38cde8177d5e8f7866d007648b7013db74d1057b700b027a79bcd893b0d493269abcd621d
EBUILD jsonschema-spec-0.1.4.ebuild 883 BLAKE2B e87ea592fc33a139f5331187ac1481eca4e882b0ed127c03a872fdb5de35d7f99248730c662facfc5b04e2f8a64d4dd7e55723302173c6e810c047dface884e1 SHA512 274cab96825ee1f5c000ed31628ba3512bb86b349fa284aba43b24f2981bc62118b9ec1174d7357d100ee752763d82695c032fbadad57f5945b52f9788c23591
+EBUILD jsonschema-spec-0.1.5.ebuild 974 BLAKE2B cd30e483f2ddcf21db668eef5511054d89e2f850e0f7831210801da88ea953e833150824d818ce7bea87291b732e044f26585d72406064f5cff6ee40110fa794 SHA512 50d9f89d3d151bf32b07c06537061be5f16a1b7e3c33fc630ab2c11526401edb92e3fbad71d293facc3e96c939db91d6d29bd280d2c47e73ad383e150bc6119b
MISC metadata.xml 404 BLAKE2B 2e76fe1eb441114cff26e2e60d36d2d38da053ca524a29f568d2b4af325021ab560545da43cdd0d5d3404e73ebcdb9b534da0b7de52c2acee5d3f2ed6511ee4e SHA512 58238e60fc20d210167afe2abcfdbbd826a693b5d587953437294c2c0e1ea9161486e2c583d29a7e2a0c8343e70e7688213ed011eacd155c53e232b336986701
diff --git a/dev-python/jsonschema-spec/jsonschema-spec-0.1.5.ebuild b/dev-python/jsonschema-spec/jsonschema-spec-0.1.5.ebuild
new file mode 100644
index 000000000000..11106a6a143e
--- /dev/null
+++ b/dev-python/jsonschema-spec/jsonschema-spec-0.1.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSONSchema Spec with object-oriented paths"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema-spec/
+ https://github.com/p1c2u/jsonschema-spec/
+"
+SRC_URI="
+ https://github.com/p1c2u/jsonschema-spec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ <dev-python/jsonschema-4.18[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pathable[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ dev-python/pathable[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/--cov/d' -i pyproject.toml || die
+ # remove impossible constraint
+ sed -i -e '/typing.extensions/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}