summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema-spec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-12 14:20:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-12 14:20:03 +0100
commit522b6bf7e1f6133c288b94a77fc5e3d8eef2c179 (patch)
treec6624f4b91276a0312ca31ebfa276732608dddba /dev-python/jsonschema-spec
parent4d0ca679fbcb59301ffc7af98794c411c5061a0b (diff)
gentoo auto-resync : 12:06:2023 - 14:20:02
Diffstat (limited to 'dev-python/jsonschema-spec')
-rw-r--r--dev-python/jsonschema-spec/Manifest2
-rw-r--r--dev-python/jsonschema-spec/jsonschema-spec-0.1.6.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/jsonschema-spec/Manifest b/dev-python/jsonschema-spec/Manifest
index 6b65b1671ba3..4f90a9f04b58 100644
--- a/dev-python/jsonschema-spec/Manifest
+++ b/dev-python/jsonschema-spec/Manifest
@@ -1,5 +1,7 @@
DIST jsonschema-spec-0.1.4.gh.tar.gz 30903 BLAKE2B eae7ba8b811dfd14d9b2e33d3355bf8c98e088b1a8fa3314300dcc7edae31727cc5a01d0a06af412b8c7d59eca69ba816f6eb2683e997719fd300a3445e96cfd SHA512 6b3d1710fdd8c43a0f38d0687c95e4e70c55df964dc597e4a00abad3459610829bd90190b21c512c70d46498d98b80ecc2422eb73d7822539841ff10bc7c2c4f
DIST jsonschema-spec-0.1.5.gh.tar.gz 36035 BLAKE2B 4e6019fb1c7f5e85a03488e00ef080798bc6e3e06999d9c9c931072c640fd74b5125882e43dca26bad1acc3bdacb06a26f2c95dff25339e3f8b785d759085a49 SHA512 c76b15a3ead9498696c80cf7a378a675194837f04cd88d81be5213a38cde8177d5e8f7866d007648b7013db74d1057b700b027a79bcd893b0d493269abcd621d
+DIST jsonschema-spec-0.1.6.gh.tar.gz 36043 BLAKE2B e85cad336d6b5ed11d6a51c8fab2c28826f6a9836ad50d2423b23bef047c338307d3e9430f1d151dbaf7a92574c9899dbfd016c570456996250e8d7634373313 SHA512 78ea06a78fd25006d270e2c5033645133ee79b0f45cbfc54e250d4225a36beac59cf9aa92f15fd51bd101fac20fee990d693ab91d8343cd6a298d71735c80884
EBUILD jsonschema-spec-0.1.4.ebuild 883 BLAKE2B e87ea592fc33a139f5331187ac1481eca4e882b0ed127c03a872fdb5de35d7f99248730c662facfc5b04e2f8a64d4dd7e55723302173c6e810c047dface884e1 SHA512 274cab96825ee1f5c000ed31628ba3512bb86b349fa284aba43b24f2981bc62118b9ec1174d7357d100ee752763d82695c032fbadad57f5945b52f9788c23591
EBUILD jsonschema-spec-0.1.5.ebuild 974 BLAKE2B cd30e483f2ddcf21db668eef5511054d89e2f850e0f7831210801da88ea953e833150824d818ce7bea87291b732e044f26585d72406064f5cff6ee40110fa794 SHA512 50d9f89d3d151bf32b07c06537061be5f16a1b7e3c33fc630ab2c11526401edb92e3fbad71d293facc3e96c939db91d6d29bd280d2c47e73ad383e150bc6119b
+EBUILD jsonschema-spec-0.1.6.ebuild 886 BLAKE2B 1cef95edd89d5ea9c713e597afd2f0a53f8d9cab8836f7663807681144396684999c4ea244b3be9259e2a1504fed5c3ad7837b4f3b87e1ff5a8bc3be728c04dc SHA512 26697d6b1ed19e27a38eb54fa00cee2201c7751dbc5ade49ad213f56159ddac21e79073024902e9c7be14862d241a4fa615312628a90aa221551fe07a13674ed
MISC metadata.xml 404 BLAKE2B 2e76fe1eb441114cff26e2e60d36d2d38da053ca524a29f568d2b4af325021ab560545da43cdd0d5d3404e73ebcdb9b534da0b7de52c2acee5d3f2ed6511ee4e SHA512 58238e60fc20d210167afe2abcfdbbd826a693b5d587953437294c2c0e1ea9161486e2c583d29a7e2a0c8343e70e7688213ed011eacd155c53e232b336986701
diff --git a/dev-python/jsonschema-spec/jsonschema-spec-0.1.6.ebuild b/dev-python/jsonschema-spec/jsonschema-spec-0.1.6.ebuild
new file mode 100644
index 000000000000..4c1b2bdda25c
--- /dev/null
+++ b/dev-python/jsonschema-spec/jsonschema-spec-0.1.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSONSchema Spec with object-oriented paths"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema-spec/
+ https://github.com/p1c2u/jsonschema-spec/
+"
+SRC_URI="
+ https://github.com/p1c2u/jsonschema-spec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ <dev-python/jsonschema-4.18[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pathable[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ dev-python/pathable[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/--cov/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}