summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema-spec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-17 18:28:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-17 18:28:08 +0000
commit1f254b1ee917690b4f8f7738fdcfc295ee304ff7 (patch)
tree136ad1b72b899873af1ab7e8fcc6ec343484f41f /dev-python/jsonschema-spec
parentbcf596975a1c2450e077c80c84017c54198f216c (diff)
gentoo auto-resync : 17:03:2023 - 18:28:08
Diffstat (limited to 'dev-python/jsonschema-spec')
-rw-r--r--dev-python/jsonschema-spec/Manifest2
-rw-r--r--dev-python/jsonschema-spec/jsonschema-spec-0.1.4.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/jsonschema-spec/Manifest b/dev-python/jsonschema-spec/Manifest
index be2a6ee63db6..ec1cfb435ccd 100644
--- a/dev-python/jsonschema-spec/Manifest
+++ b/dev-python/jsonschema-spec/Manifest
@@ -1,3 +1,5 @@
DIST jsonschema-spec-0.1.3.gh.tar.gz 30794 BLAKE2B 545eda0aef433eb62cd02bbcc4d07469b26c477bbf572d71bcb4eb126acc5ab912f5f80c0699305b37f7f526f36910bcb019d66a763e679846bb20a5b01eb813 SHA512 95465c43b842289ed28dd78ec06614d77b2bbf7d9d69e5dc4b89008740d0cc85e5b3319acd66d0142b533425e8f150c4edbbf15b7f8e3bdefb28b81193a13432
+DIST jsonschema-spec-0.1.4.gh.tar.gz 30903 BLAKE2B eae7ba8b811dfd14d9b2e33d3355bf8c98e088b1a8fa3314300dcc7edae31727cc5a01d0a06af412b8c7d59eca69ba816f6eb2683e997719fd300a3445e96cfd SHA512 6b3d1710fdd8c43a0f38d0687c95e4e70c55df964dc597e4a00abad3459610829bd90190b21c512c70d46498d98b80ecc2422eb73d7822539841ff10bc7c2c4f
EBUILD jsonschema-spec-0.1.3.ebuild 836 BLAKE2B b7c5875215dd69aa6f229e962675b2d8554d432efbc0f4e4423a26d78862f2958320b7f12cd3fe370a3b2759d3abc2a6cd5995ef380f0a2f719aa2f15ee6cdf0 SHA512 7dbc5cb7e06453c222c54674c92378cc52ef4d8d44e1e48c4b912f84f4ee2ed19b64bcfe8e5b880ad584fc9273fe1da557040c315c14c13a9c3f407306d1aefb
+EBUILD jsonschema-spec-0.1.4.ebuild 885 BLAKE2B 85b46229c8c313665c6bc0152a8f139d1eac567af6941c8223da70978e7bf3d05d62c816d7a11507295f35ab2144ea3203dcd96d07a70d7329444e75c7eef293 SHA512 47cd58e6dc14054920b2da534a54265e55aab69bb7e0edc3f112cf497b2ac65e938160272a0db9f92ccbb97dad08e822d0872dfca311cf8df2f9d912eb9c541e
MISC metadata.xml 404 BLAKE2B 2e76fe1eb441114cff26e2e60d36d2d38da053ca524a29f568d2b4af325021ab560545da43cdd0d5d3404e73ebcdb9b534da0b7de52c2acee5d3f2ed6511ee4e SHA512 58238e60fc20d210167afe2abcfdbbd826a693b5d587953437294c2c0e1ea9161486e2c583d29a7e2a0c8343e70e7688213ed011eacd155c53e232b336986701
diff --git a/dev-python/jsonschema-spec/jsonschema-spec-0.1.4.ebuild b/dev-python/jsonschema-spec/jsonschema-spec-0.1.4.ebuild
new file mode 100644
index 000000000000..66fd3efcb98b
--- /dev/null
+++ b/dev-python/jsonschema-spec/jsonschema-spec-0.1.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSONSchema Spec with object-oriented paths"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema-spec/
+ https://github.com/p1c2u/jsonschema-spec/
+"
+SRC_URI="
+ https://github.com/p1c2u/jsonschema-spec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ <dev-python/jsonschema-4.18[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pathable[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ dev-python/pathable[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/--cov/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}