summaryrefslogtreecommitdiff
path: root/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-17 09:07:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-17 09:07:15 +0000
commit9bd54251864651f49e673a08aec9ef79cfe08f04 (patch)
treebac28788ab54849c5d28edb190a687167737e736 /dev-python/jsonrpclib/jsonrpclib-9999.ebuild
parent6b933047f46efec1aa747570f945344254227457 (diff)
gentoo resync : 17.12.2017
Diffstat (limited to 'dev-python/jsonrpclib/jsonrpclib-9999.ebuild')
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-9999.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/jsonrpclib/jsonrpclib-9999.ebuild b/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
index d423c16be33e..de6e1a8301bc 100644
--- a/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
+++ b/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
@@ -1,21 +1,21 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
+EAPI="6"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
inherit distutils-r1
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/joshmarshall/jsonrpclib.git"
- inherit git-2
+ EGIT_REPO_URI="https://github.com/tcalmant/jsonrpclib.git"
+ inherit git-r3
else
- SRC_URI="https://github.com/joshmarshall/jsonrpclib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/tcalmant/jsonrpclib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~mips ~x86"
fi
DESCRIPTION="python implementation of the JSON-RPC spec (1.0 and 2.0)"
-HOMEPAGE="https://github.com/joshmarshall/jsonrpclib"
+HOMEPAGE="https://github.com/tcalmant/jsonrpclib"
LICENSE="Apache-2.0"
SLOT="0"
@@ -24,3 +24,7 @@ IUSE=""
DEPEND=""
RDEPEND="${DEPEND}
dev-python/simplejson"
+
+python_test() {
+ esetup.py test || die "tests failed with ${EPYTHON}"
+}