summaryrefslogtreecommitdiff
path: root/dev-python/jsonpointer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-08 20:11:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-08 20:11:47 +0100
commitf625b9919a60a30f1bd860f7d1b2eac183ced593 (patch)
tree7543f00925ff7277e31881de0a87801681f6f92f /dev-python/jsonpointer
parente3872864be25f7421015bef2732fa57c0c9fb726 (diff)
gentoo resync : 08.08.2018
Diffstat (limited to 'dev-python/jsonpointer')
-rw-r--r--dev-python/jsonpointer/Manifest2
-rw-r--r--dev-python/jsonpointer/jsonpointer-2.0.ebuild22
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/jsonpointer/Manifest b/dev-python/jsonpointer/Manifest
index fa385ef262b8..f9f31d72fe26 100644
--- a/dev-python/jsonpointer/Manifest
+++ b/dev-python/jsonpointer/Manifest
@@ -1,3 +1,5 @@
DIST jsonpointer-1.10.tar.gz 7577 BLAKE2B b4472cd9ead51fe75f2e53690d4c0378cb6b5dccae240bc1bf264bff9df15bdfab379b1043221e66074e08c3393ecf729e4f95721fcb324fe8b710cd49d7f064 SHA512 b2df5f19b14b670825b18f7da4ca50b089beb2ccbb1c69acfc904eed82b5315ad19940b4aaa8f8504c2fc7d477778d65e31f492dd30ee8b5ba95ccfd0eaeb9b1
+DIST jsonpointer-2.0.tar.gz 8699 BLAKE2B 7b52955aa691a1bba327df6674704503b009101d0dd94587620a684ca9310128e3afcc62cedabd92106deffc3a6a3434a72123fc804224ae68ade8751462bf14 SHA512 e8e2b03c12c3fc5f65816fc71d1c07135ef74a0c912286f5b8bef2d9e21b8ae6e766d1aa2104b3eeb0e53928034321f25b203386ac3f5641b54b0641f6a08137
EBUILD jsonpointer-1.10.ebuild 643 BLAKE2B fc25db9393b2624bb0a2e0dae47bb968f58761cc02655c142e083317c5e2a8df8ec080dbc4b4e9e1243938c78eb46b3ae9e6dea1ea6df68e24fa27ad43850ca4 SHA512 f14a50dd7aba6fcce891345b1918aef3b7e223925ed7d096406a06a190d5402d8ac5b765d7217aa512626a7b333528ac3932fb676a2887a3da666f67a2858a01
+EBUILD jsonpointer-2.0.ebuild 639 BLAKE2B 3151f2b07eaae6cfb9feca80774b8d4d12cb2b86a20dd80bc9c10c46af7665233401c9f5ed85f7b55c66789907e4dfcffd3b368cb392044b8874a835ec9df12f SHA512 1e4106dd20e16fd7fd3974b8decd375a82272ed3f010e8b7e4df28e788ba99d2be721c21f267ce008e40f9798ebaab469e9d50ef3c166e21a7b3940ba9581048
MISC metadata.xml 702 BLAKE2B 20a9bbb2163d360f6797170b59d71a8233c7e7bc9f66f1809bd5c70d4c460a464fc0d8ad831f4ff08bb28df0c2ff77c0a0fd483a6295a7090fa73d1a3a4902ec SHA512 0f25c1d5667c07fc6382d958c6f150412de3208a9f21218bcff55c32354e86e17338d3b2480dbb8c7633f1b0d95211c9510aa4cbc9e5392490b6c3904babb9f8
diff --git a/dev-python/jsonpointer/jsonpointer-2.0.ebuild b/dev-python/jsonpointer/jsonpointer-2.0.ebuild
new file mode 100644
index 000000000000..7a038f0fa5b7
--- /dev/null
+++ b/dev-python/jsonpointer/jsonpointer-2.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
+HOMEPAGE="https://github.com/stefankoegl/python-json-pointer https://pypi.org/project/jsonpointer/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}