summaryrefslogtreecommitdiff
path: root/dev-python/jsonpointer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-python/jsonpointer
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-python/jsonpointer')
-rw-r--r--dev-python/jsonpointer/Manifest2
-rw-r--r--dev-python/jsonpointer/jsonpointer-2.2.ebuild19
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/jsonpointer/Manifest b/dev-python/jsonpointer/Manifest
index 6d8b3c9de566..173ad27cd096 100644
--- a/dev-python/jsonpointer/Manifest
+++ b/dev-python/jsonpointer/Manifest
@@ -1,3 +1,5 @@
DIST jsonpointer-2.1.tar.gz 8190 BLAKE2B 5b9d0b0a27c6e2d133de67cf0ff9442e639a06011005f94cb425568fd3e5678b4832e9467720261fb85669e8b83eac73b1cfa8058adbd78d46339cdf8359561c SHA512 4eed8c7fa908ce3ca79884e98b1b0e818d24515f6b7b2067daa49ab6dbd989be4bc43f387e980773c9fc17bca89d2039750cb0df76675259050e3f48c16da3b6
+DIST jsonpointer-2.2.tar.gz 8292 BLAKE2B 837c6c8a87e0d19cbeed07769afb29fa56ddfb629f05d0f2de94f4e94af916358f71892e085c7c18b9c711ac8e604a0ff7d1fa7dfbf52836edb1a600e5ed390b SHA512 ce680e3915ea9db915095c4106e58acf7cc2148bdc67944e03e225a33b882964ed0c154fdbe8415f787c5aa5bfa007b9e1fd2a31689dcadc88b1560931ca6a6d
EBUILD jsonpointer-2.1.ebuild 619 BLAKE2B 30dca4d2fb8368522fa8269965e91e0d016ece6d185618a4e8588be58c7bb5a8b59d571ce1b43e8b713ab4dee9ae89cd0c9a892b5e52e268d02620d15dff964b SHA512 f8e9283544ec697bb78f50c4c0afe892ec91b55d43e93cf3a93248c5d73932db504d537f7a56dd924bf3a31cb7ed96ec5ab673a82946a781daaeab2b14c6cfc6
+EBUILD jsonpointer-2.2.ebuild 626 BLAKE2B 349862f6c2a5d1671179ffb6d3fdc7b5212803287f7bfa5f75c95a341055e68df74b301a20da16da0d7ea8e1348132a5df6d03cf8b14b5a95046c6838cc64b17 SHA512 9159a0fd1feb61e25d8035c4a9475b4a3f55fc5663551bf40a3b6ee3f193af65ef41edc391f27ee89902bf0166e40750ec567f2d8d96de52909528850e6b04aa
MISC metadata.xml 728 BLAKE2B f14151531af31af82ca130caa61b9c9af6cded41678899d5413f076d7fb6da93e2c4aad3ff27e66f64ba56b8ccc70c065763157312438f32ccf2573766ee160d SHA512 6b19c6b90a5d151d4837d8be641b52ffc4e7eb3be956760d1cffbb2af03258c5a2b81a9074daee9b667fcb5df7223836130729cd5ea4130d2b7f3c7415e62569
diff --git a/dev-python/jsonpointer/jsonpointer-2.2.ebuild b/dev-python/jsonpointer/jsonpointer-2.2.ebuild
new file mode 100644
index 000000000000..46bd94469a48
--- /dev/null
+++ b/dev-python/jsonpointer/jsonpointer-2.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
+HOMEPAGE="https://github.com/stefankoegl/python-json-pointer https://pypi.org/project/jsonpointer/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}