summaryrefslogtreecommitdiff
path: root/dev-python/jsonpointer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/jsonpointer
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/jsonpointer')
-rw-r--r--dev-python/jsonpointer/Manifest1
-rw-r--r--dev-python/jsonpointer/jsonpointer-2.0-r1.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/jsonpointer/Manifest b/dev-python/jsonpointer/Manifest
index 67a27b009e4c..1a016fcd34cc 100644
--- a/dev-python/jsonpointer/Manifest
+++ b/dev-python/jsonpointer/Manifest
@@ -1,5 +1,6 @@
DIST jsonpointer-1.10.tar.gz 7577 BLAKE2B b4472cd9ead51fe75f2e53690d4c0378cb6b5dccae240bc1bf264bff9df15bdfab379b1043221e66074e08c3393ecf729e4f95721fcb324fe8b710cd49d7f064 SHA512 b2df5f19b14b670825b18f7da4ca50b089beb2ccbb1c69acfc904eed82b5315ad19940b4aaa8f8504c2fc7d477778d65e31f492dd30ee8b5ba95ccfd0eaeb9b1
DIST jsonpointer-2.0.tar.gz 8699 BLAKE2B 7b52955aa691a1bba327df6674704503b009101d0dd94587620a684ca9310128e3afcc62cedabd92106deffc3a6a3434a72123fc804224ae68ade8751462bf14 SHA512 e8e2b03c12c3fc5f65816fc71d1c07135ef74a0c912286f5b8bef2d9e21b8ae6e766d1aa2104b3eeb0e53928034321f25b203386ac3f5641b54b0641f6a08137
EBUILD jsonpointer-1.10.ebuild 638 BLAKE2B 2ebcf0644b5d6cd7baba9c1fb7276b4fa1b3ea22dd545f5cdbf1d56ca51ad4ba60c90aaf48a8f42df44ae456da5bd891b24d3cc1703c22a1c4e0a288c9228388 SHA512 a09d13d511454edb9fca25a01e64e4b47bb8e976d4cf4c063f7b3d85f33407ae5c1ade3342c79df5180c0185cf2394fe4ac9378b0b538e9905aa6942b55aca66
+EBUILD jsonpointer-2.0-r1.ebuild 645 BLAKE2B 6c0692c55d1371340be9a16669479d454cef008f630ef24bcff8abe845ac8c558c3bf5373f33802e7d40f76ab82d4d73d95054603c5b6107472ccd135e1a9dd7 SHA512 e29d4e9824bcf9dbc17060823dcd02fd62a57767f85ef1ad08252955b979b925f60b971fdf9b888a983e0cc956840b52cf7cead549655fd2a06b1af13759962a
EBUILD jsonpointer-2.0.ebuild 632 BLAKE2B 155809e8ca9ec27526b9642fa878c2aece07dbfcbb2a08c1a82a23f52d1cc4076684d04db0f188193b92d1d548d28a51da939c260175812a0709f36962ec4d9e SHA512 5bbfeacf0d847f965ad2be8470b1cd940c9ae3e3cd4fd9b16d9e00f6abdea5430ae625bc427cf4a6414003b3ad0b7201773379ba9836ae70603a6d9a6b91c474
MISC metadata.xml 702 BLAKE2B 20a9bbb2163d360f6797170b59d71a8233c7e7bc9f66f1809bd5c70d4c460a464fc0d8ad831f4ff08bb28df0c2ff77c0a0fd483a6295a7090fa73d1a3a4902ec SHA512 0f25c1d5667c07fc6382d958c6f150412de3208a9f21218bcff55c32354e86e17338d3b2480dbb8c7633f1b0d95211c9510aa4cbc9e5392490b6c3904babb9f8
diff --git a/dev-python/jsonpointer/jsonpointer-2.0-r1.ebuild b/dev-python/jsonpointer/jsonpointer-2.0-r1.ebuild
new file mode 100644
index 000000000000..53f3cf518fe5
--- /dev/null
+++ b/dev-python/jsonpointer/jsonpointer-2.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
+HOMEPAGE="https://github.com/stefankoegl/python-json-pointer https://pypi.org/project/jsonpointer/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}