summaryrefslogtreecommitdiff
path: root/dev-python/jsonpointer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-27 07:34:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-27 07:34:25 +0100
commit61faa1ea0e8302df305bc281038fc00dc7eb1dd4 (patch)
tree80638756ce07f0db3bcdc33653970fa5452df743 /dev-python/jsonpointer
parent00757bf15f0eb42661625ed16888d00af9a79561 (diff)
gentoo auto-resync : 27:06:2023 - 07:34:25
Diffstat (limited to 'dev-python/jsonpointer')
-rw-r--r--dev-python/jsonpointer/Manifest2
-rw-r--r--dev-python/jsonpointer/jsonpointer-2.4.ebuild23
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/jsonpointer/Manifest b/dev-python/jsonpointer/Manifest
index 01f1c14a6b87..569d7f48fe46 100644
--- a/dev-python/jsonpointer/Manifest
+++ b/dev-python/jsonpointer/Manifest
@@ -1,3 +1,5 @@
DIST jsonpointer-2.3.tar.gz 9295 BLAKE2B 8a33c8ce21721b6c402a44d3d1572a767e3b7485fa1dd80baf98120c9822412841cc21e3bc2d6b7e058793ab4ade5993712c689631cb4a1237afc1d7f36e6bdf SHA512 e04da474a5ec376d1cd2c764c2d7a11ac296450df199449994cb1dedf02a49df3ae3a4e75b2963370dba1da166464602b849a79609f7a98d8246dab0b342c819
+DIST jsonpointer-2.4.tar.gz 9254 BLAKE2B 423a4ef71cd1029fe2c473940794a041df4c3422b8292d80290be7f11ac0e6b123d3074cb6f66a3d860274bdf5b0cd0716d24c9ee50b65e06139375dc93c84ad SHA512 41cc0f8b525bec4b18801aeaec1b2432c5f6475dd3f2bc0fb363cf6ceaac5c64e7993c72130a40c64427218a1eac352e93464137fe17427b9f8a34ae09699f4e
EBUILD jsonpointer-2.3.ebuild 623 BLAKE2B b61300a995a6b3d14b21a131d54a24d7109e63ef93758316ce34442da17d2bd6839f68e405ee3960302225e2ede16d2c1af8382ffca42abebdd87b7dfeddab3a SHA512 2b3bdfeee207e8011f03238527dc5893d3fb9985eb53bb3701de77b37fd06b96c21253c5a2d1e4df0dbf6b5a47a0843de623f7e4fed77bfc125012739a04d254
+EBUILD jsonpointer-2.4.ebuild 631 BLAKE2B 3bae5d4a912f6aeff07f74123f8bf488522275143b50b4063be1f12f8a4fc29c326f8eeb98f047d7d82cbdfbd3167a253ebf20a260c88bd05992d8fa43b263c2 SHA512 ccf9a53adfe8fa57c5795e143d6b271db2cffc13b672c97a8a58f5c863136548f850c0e2d735302c347835ba806b917f6a3bafc546a2165295ee23e2dd754895
MISC metadata.xml 728 BLAKE2B f14151531af31af82ca130caa61b9c9af6cded41678899d5413f076d7fb6da93e2c4aad3ff27e66f64ba56b8ccc70c065763157312438f32ccf2573766ee160d SHA512 6b19c6b90a5d151d4837d8be641b52ffc4e7eb3be956760d1cffbb2af03258c5a2b81a9074daee9b667fcb5df7223836130729cd5ea4130d2b7f3c7415e62569
diff --git a/dev-python/jsonpointer/jsonpointer-2.4.ebuild b/dev-python/jsonpointer/jsonpointer-2.4.ebuild
new file mode 100644
index 000000000000..a2dc4885530d
--- /dev/null
+++ b/dev-python/jsonpointer/jsonpointer-2.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
+HOMEPAGE="
+ https://github.com/stefankoegl/python-json-pointer/
+ https://pypi.org/project/jsonpointer/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}