summaryrefslogtreecommitdiff
path: root/dev-python/jsonpickle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/jsonpickle
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/jsonpickle')
-rw-r--r--dev-python/jsonpickle/Manifest3
-rw-r--r--dev-python/jsonpickle/jsonpickle-0.9.3.ebuild50
-rw-r--r--dev-python/jsonpickle/metadata.xml12
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/jsonpickle/Manifest b/dev-python/jsonpickle/Manifest
new file mode 100644
index 000000000000..29e7be89cb30
--- /dev/null
+++ b/dev-python/jsonpickle/Manifest
@@ -0,0 +1,3 @@
+DIST jsonpickle-0.9.3.tar.gz 60489 BLAKE2B 4767809a3bd5816343e9081bdaf45cdec8dfd1e28b832675e01ae415c1ac081d0a84e2827051520999d11d0dc28a62bdd09285cf384fff0f941d3a571064e2bf SHA512 38de2ab2c15e0e28323a8cc83b0c0b0631f2f678f620e8738fee19c71492f011aa7eec428b859574a0066b9e24a08bde911a283736757964035befe3042f2e06
+EBUILD jsonpickle-0.9.3.ebuild 1547 BLAKE2B ccc73407f46a0b0fa114809f696cb7a659d2208f1abde5e3f7ecf4a5f381d3385f1f9ee881746a58608e909704bc20076a4200d9f1d68ad25bc1c2b116179ba9 SHA512 f2be306a6ca0b0c7167da1cc96f3613d050ae8e978faca736eb9ffe5c766f0c2347362860c20bc9180fe09089aba47286967aa2c05a82ba961398a41b2e86048
+MISC metadata.xml 386 BLAKE2B 486aa3823ac1ae6b816068ae775da293fedab7120df504f2bb64cbbd026e1ad4ac2041acfb48035b5816616dedd46a5f4bedf8c63daad2315727cdbaedcd15ad SHA512 12590542127c674ae6c8123b20ce5c7ed6815f9129eefb95ef3a8c064fdc25477765d397cb7d7e62772475306c0ac7389a7155655576845b936866470302b759
diff --git a/dev-python/jsonpickle/jsonpickle-0.9.3.ebuild b/dev-python/jsonpickle/jsonpickle-0.9.3.ebuild
new file mode 100644
index 000000000000..0779980ec929
--- /dev/null
+++ b/dev-python/jsonpickle/jsonpickle-0.9.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
+HOMEPAGE="https://github.com/jsonpickle/jsonpickle/ https://pypi.org/project/jsonpickle/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+# There are optional json backends serializer/deserializers in addition to those selected here
+# jsonlib, yajl. demjson added
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+ dev-python/demjson[${PYTHON_USEDEP}]
+ "
+DEPEND="test? ( ${RDEPEND} )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/sphinxtogithub[${PYTHON_USEDEP}]' python2_7) )"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading during doc build
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && sphinx-build -b html -c docs/source/ docs/source/ docs/source/html
+}
+
+python_test() {
+ # An apparent regression in tests
+ # https://github.com/jsonpickle/jsonpickle/issues/124
+ einfo "testsuite has optional tests for package demjson"
+ ${PYTHON} tests/runtests.py || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/source/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jsonpickle/metadata.xml b/dev-python/jsonpickle/metadata.xml
new file mode 100644
index 000000000000..6ee6ba05b2b7
--- /dev/null
+++ b/dev-python/jsonpickle/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">jsonpickle</remote-id>
+ <remote-id type="github">jsonpickle/jsonpickle</remote-id>
+ </upstream>
+</pkgmetadata>