summaryrefslogtreecommitdiff
path: root/dev-python/jsonpath-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-13 04:04:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-13 04:04:07 +0100
commit7b5306e0d287565138e8b051e32f57e6af6ae0ed (patch)
tree7e232eacc1f02fc6abb1c416458b5a564d0e295f /dev-python/jsonpath-ng
parent3980ecf15e6202ac2f2015045b549600e709b721 (diff)
gentoo auto-resync : 13:10:2024 - 04:04:06
Diffstat (limited to 'dev-python/jsonpath-ng')
-rw-r--r--dev-python/jsonpath-ng/Manifest2
-rw-r--r--dev-python/jsonpath-ng/jsonpath-ng-1.7.0.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/jsonpath-ng/Manifest b/dev-python/jsonpath-ng/Manifest
index 41864aade300..f07669df5eb0 100644
--- a/dev-python/jsonpath-ng/Manifest
+++ b/dev-python/jsonpath-ng/Manifest
@@ -1,3 +1,5 @@
DIST jsonpath-ng-1.6.1.tar.gz 36024 BLAKE2B ed6b47974e55c8bb5e086249c24d847dc0e1719d6912c0097bf6bcc06ad096f54b99f9c7053c088bb2efae4c612a49364cae3b061593890508e408b6776e73fb SHA512 84f4ceb3b2e76665b56df6c6cd9bf8c155d3677cc6b4798531bb35e95a591e98186c7fa756d400cbbde4c62acc7da077d0fdf989f5101846fb74bba83dd4be58
+DIST jsonpath-ng-1.7.0.tar.gz 37838 BLAKE2B fbd9a77e332eb691444f29f27de1f00f6bd68d2ba729e94940a55f13fe948d73d46f3b54dc3e1097165164aa011ee7f669ad01324031d869ca33f2da5dba5991 SHA512 91dfedeee3ff3eab7df318ca02572caeb03a70a02146e281d849c7263147269610a65d81738972c436b717cef18c3a10efe106cf013e651f7acaa5ef81d71705
EBUILD jsonpath-ng-1.6.1.ebuild 572 BLAKE2B ee83331d2b58fb7274b3caf06ef4f623f44003ff168112bd097ad5ee17f24af555ae120dd665dfccd0b7e0c6436166d3681f510bc545aec3a4eb6c4967844748 SHA512 bedb946e5ccb534896264544f4e9965dd78c8fa497db3c3766401277691d4113b4a0e67edee37fe64cb0639a0461c7ce4b9ac7f9c3b0e2b2715843976d158cd3
+EBUILD jsonpath-ng-1.7.0.ebuild 575 BLAKE2B 30171044cdb39c97441a85ce210195dcc94ad7c60f1fac59c6286fa2ae97e6cccb6c2df4a0ff11da4c06e58df9b5a18d1c1b314c44585f834a7a19efc73858df SHA512 55ec8447a1027afd18df1d44895556f33a50c67f1b3007066229f8873a094498255d4598507050e165ef5a619a36b0fe57b8c2c7df04755a8b5bde2a850e9a5c
MISC metadata.xml 377 BLAKE2B 773ec2b58b38244bf4925bcb99751e180092bf55a4b20b937647867a696c673592bf0bef11e2835820cad1da51783bfad76bde86200f98b0f2f1c7bac491f36e SHA512 7b0f8455e40e1db69768a1d451888c04a6805b78fbf5f0d81e4adae47539acdd3b7d4e0f33a93e81261ea7d1c5cb48fbe460d4516e3a85a86f52023270744309
diff --git a/dev-python/jsonpath-ng/jsonpath-ng-1.7.0.ebuild b/dev-python/jsonpath-ng/jsonpath-ng-1.7.0.ebuild
new file mode 100644
index 000000000000..c61083eed613
--- /dev/null
+++ b/dev-python/jsonpath-ng/jsonpath-ng-1.7.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python JSONPath Next-Generation"
+HOMEPAGE="
+ https://github.com/h2non/jsonpath-ng/
+ https://pypi.org/project/jsonpath-ng/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/oslotest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest