summaryrefslogtreecommitdiff
path: root/dev-python/jsonpatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-01 15:26:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-01 15:26:21 +0100
commitd14501acaa1e3634cb0a6f6e356923391009eb46 (patch)
tree6fca6701ec7850e503efaf22370bab079a735dd8 /dev-python/jsonpatch
parent9b9c22874161d13ca8d50c952d549f2390f3f179 (diff)
gentoo auto-resync : 01:06:2023 - 15:26:21
Diffstat (limited to 'dev-python/jsonpatch')
-rw-r--r--dev-python/jsonpatch/Manifest2
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.32-r1.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/jsonpatch/Manifest b/dev-python/jsonpatch/Manifest
index 6500494381cf..e5eea190be13 100644
--- a/dev-python/jsonpatch/Manifest
+++ b/dev-python/jsonpatch/Manifest
@@ -1,3 +1,5 @@
DIST jsonpatch-1.32.tar.gz 27988 BLAKE2B b60dc7607f644f1ffd095486c237e3bb537b465132725e98fc8799a42a92dcbb43e1e41d281fbc2ce2c4efec327ad681d7740129be55d94c51321e620d084d95 SHA512 4e2978555dd506e09553014d426c4e3a6c6d5c865428f11450952704007c8a0b2060b945cf1fa33a128151427e1c66919891466e095e96fff4316304f0b3ad1d
+DIST python-json-patch-1.32.gh.tar.gz 27988 BLAKE2B b60dc7607f644f1ffd095486c237e3bb537b465132725e98fc8799a42a92dcbb43e1e41d281fbc2ce2c4efec327ad681d7740129be55d94c51321e620d084d95 SHA512 4e2978555dd506e09553014d426c4e3a6c6d5c865428f11450952704007c8a0b2060b945cf1fa33a128151427e1c66919891466e095e96fff4316304f0b3ad1d
+EBUILD jsonpatch-1.32-r1.ebuild 956 BLAKE2B 03001cac25cb82788c59b6a155458a53fb2cc19dc2710d5155e999b8e5f754d5f584935c08b90a45196cf3c85549d01f4b9298cd2a3ead7cfa9f55b62f009ac4 SHA512 a13b9e0a0d344324d9d2403729d3011a0f8f576dfaae26b7c0f9239c63c06253acee3e577c3a54a1cfd97512abe71d0319b1a4b46117aa61787e805f3de7b95c
EBUILD jsonpatch-1.32.ebuild 849 BLAKE2B e5845e6cc79e7d09249c3771fb57b79f023d0d0033387a28860a909293b3fb816396f3de7a3719c5a5ee39e80ab3fe09dc9e0a1dd64d7cb9f80c9b74baece724 SHA512 df87a48b28d40ddc236adda9afec0f499a92dae6102c57d57d50300acfc60f58fd356290dbc6f4952d284f79e8f9952467f1db1f0aed19b9e1c15944ff901664
MISC metadata.xml 705 BLAKE2B 4c59d56bf1f2eee88fd6a9284f13055ff97cc9c787ad3e03b983b8ba0c995fd34148e9a6ceb0f3f4cd1226aff0e60c6f7bc23e26e8da375d3527148ed49766ed SHA512 0323b39edf87ff697dc30deefd0568706e8318e54fb072902d5b60a31be65c39966d727f441f524715ce4c3a0958b9264d82ace03210c9550115a5b3fda2edac
diff --git a/dev-python/jsonpatch/jsonpatch-1.32-r1.ebuild b/dev-python/jsonpatch/jsonpatch-1.32-r1.ebuild
new file mode 100644
index 000000000000..db865c090f6c
--- /dev/null
+++ b/dev-python/jsonpatch/jsonpatch-1.32-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-json-patch-${PV}
+DESCRIPTION="Apply JSON-Patches like http://tools.ietf.org/html/draft-pbryan-json-patch-04"
+HOMEPAGE="
+ https://github.com/stefankoegl/python-json-patch/
+ https://pypi.org/project/jsonpatch/
+"
+SRC_URI="
+ https://github.com/stefankoegl/python-json-patch/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/jsonpointer-1.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"
+ "${EPYTHON}" ext_tests.py || die "Tests of ext_tests.py fail with ${EPYTHON}"
+}