summaryrefslogtreecommitdiff
path: root/dev-python/jsonpatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-19 00:01:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-19 00:01:59 +0100
commit9d4810f84de876ec9d0ae03d0d44224500b41188 (patch)
tree1ca0866afdc949e405d20635d3d7f2115abb9ace /dev-python/jsonpatch
parent075fd1f8cabc5879c6eb42127fb84c3058677fde (diff)
gentoo auto-resync : 19:05:2024 - 00:01:59
Diffstat (limited to 'dev-python/jsonpatch')
-rw-r--r--dev-python/jsonpatch/Manifest2
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.33.ebuild12
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-python/jsonpatch/Manifest b/dev-python/jsonpatch/Manifest
index 11079388b4e8..c49d8234ce30 100644
--- a/dev-python/jsonpatch/Manifest
+++ b/dev-python/jsonpatch/Manifest
@@ -1,3 +1,3 @@
DIST python-json-patch-1.33.gh.tar.gz 28475 BLAKE2B 7d95ab23e09141cbe26618c91b12558d5fbfecda3e5b148d834753a364155d30859a9bdc3d321bdfcc5269f7e0170671524ae78f5fe65a8c97041bab3fb522b9 SHA512 0685f63949bee135b19d0962bdaab32ba97e02772b6650d885be57c09a2e89546222ebba1a4cf146b2f91027790b0a3ff2ea072d66dcebf9153aa601638bbfa2
-EBUILD jsonpatch-1.33.ebuild 952 BLAKE2B 7a5d23b04f41b6c28bf28c2c5d591d734b5241cfa8cea0a5741be8a39c0583132a1da71d2f659bcc97b2df0d371ba8bcff0ecc6ebe0ad55b3848418d12c06a55 SHA512 765b4e79715dc0c48b79c44e4f7221cb27e10ccc10b2a2cb081557c51148fa63fe4666d046def7e934caeb321fc6a884982b427abbc5c86b0caad1800c8bbf39
+EBUILD jsonpatch-1.33.ebuild 1169 BLAKE2B f8de6aa457c248e50e38240c1846e19e45f1b0cf516eea4da0787c4724a3d31b43ed9cc5c1986166795f4cb293558a0ec0f37fe18649bdc636fdaa12ff671242 SHA512 6dcf4380830eab214c17a85fe844502fbe3999b0753f28ca9932aa082755ea0928fba3534ad7d87910373535ca67634a981b03727424b9dec80c0cff52ad347e
MISC metadata.xml 705 BLAKE2B 4c59d56bf1f2eee88fd6a9284f13055ff97cc9c787ad3e03b983b8ba0c995fd34148e9a6ceb0f3f4cd1226aff0e60c6f7bc23e26e8da375d3527148ed49766ed SHA512 0323b39edf87ff697dc30deefd0568706e8318e54fb072902d5b60a31be65c39966d727f441f524715ce4c3a0958b9264d82ace03210c9550115a5b3fda2edac
diff --git a/dev-python/jsonpatch/jsonpatch-1.33.ebuild b/dev-python/jsonpatch/jsonpatch-1.33.ebuild
index 0dcdc83e1831..cdd23d1e88f9 100644
--- a/dev-python/jsonpatch/jsonpatch-1.33.ebuild
+++ b/dev-python/jsonpatch/jsonpatch-1.33.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -35,6 +35,14 @@ BDEPEND="
)
"
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # https://github.com/stefankoegl/python-json-patch/pull/159
+ sed -e 's/unittest.makeSuite/unittest.defaultTestLoader.loadTestsFromTestCase/' \
+ -i ext_tests.py tests.py
+}
+
python_test() {
"${EPYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"
"${EPYTHON}" ext_tests.py || die "Tests of ext_tests.py fail with ${EPYTHON}"