summaryrefslogtreecommitdiff
path: root/dev-python/jsonpatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /dev-python/jsonpatch
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'dev-python/jsonpatch')
-rw-r--r--dev-python/jsonpatch/Manifest2
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.21.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/jsonpatch/Manifest b/dev-python/jsonpatch/Manifest
index aa960eebf153..fc36ca9bd0de 100644
--- a/dev-python/jsonpatch/Manifest
+++ b/dev-python/jsonpatch/Manifest
@@ -1,5 +1,7 @@
DIST jsonpatch-1.13.tar.gz 15119 BLAKE2B 70ddb570451ac1f3d218de0f79f0a639eb922ce72084cf3bc7e89a3efedb85c6238293bf59608a51f07c33358dc0488550f982f122e89e2414ddfce26fe08c1f SHA512 23f0c92c2c8834d5e3129e9ba78ece7da2646dd60d5b0522b0f09d83e20057ef7517042e5ee8547804185d3ce23cff394c8fe78df93fad7999fae12cc5467a45
DIST jsonpatch-1.15.tar.gz 15544 BLAKE2B 1b9facd2a88a997356aeace8ddec9011f4f3c4df812fb157cd22f1210ac2e2502e8b9e18e02ea477c869758cdfc1dd0b6b4c8d76ce59ffdd68d4db14c550b572 SHA512 c5df880764b14a2fb60bb46e319bf006644ce1472d0413cf08ad151cf386e5be9fec197fd9efe0bfc3aa22dadf4078344c11211c1e8a3d5cc3ddcb998795dc91
+DIST jsonpatch-1.21.tar.gz 15208 BLAKE2B 88af93bfd7c317319d958bc3386f9551279af2fa9631c24c49231eb67398fd80f298e26957f232c9705219d4fa7033bb62f98b5d5391f6eb9f53113a1d351876 SHA512 dc902b750241833a68612430f07007080ed56dce8a7a4bdd1c042f944cd6cfdc03f4b422cc6bed6bc3b21ea390c5a281cd08181e27d6b57fc5fb657787c1d740
EBUILD jsonpatch-1.13.ebuild 801 BLAKE2B b1c54c4c546b20febb77cac5e6401e8fe5a2fbf7029577ca46c8e016005c9e0be358af91b2a3da7f37a3beb2369732703c0f42a917af201dff72e41abd1076e5 SHA512 06bec10c49dc7a3b09f3ffa8aea48c67d75feb63384a1a0714f334dcfbb0615504b27fc2526ff8cc65edb7462be8a5856d139693db688d6b610f2af1896225d9
EBUILD jsonpatch-1.15.ebuild 809 BLAKE2B 2fdc567d95b0862337ad6f6edce0fcb0180cfce4a0bd3c9f638b221eaa914af293578982b5067887f9b684d12a41f93979a235c5249d24cbe1c2607cc2515dab SHA512 288a6d1297c6d286b15b152796701cc71d9bdb9e9bf518ba50a169e31b4e56dbb67dfba2d8bb212582188b3d64a60b2fef312a66c94af626857febd821ae45a7
+EBUILD jsonpatch-1.21.ebuild 801 BLAKE2B 302951f0847de46c65b7c6349dd990ade5b6a87518ab82e2ba334f0351946eb13405b4e252fd7f66d65534d703eb24914e80b87831ed8212a07c909bf8b4a0f7 SHA512 087eeba0acf5d1a6c9a3017d097ee699efbda8a39cfe62c508197446dd73fac5be8de6e71ffa4938a5fb1d70c16f0bf47cd56da46488fa8169518466a4e3ca3a
MISC metadata.xml 679 BLAKE2B ecac7a9a6da1482f0585c29ab1e7f1ea3729dc4c2b4640440b0a1a5eddbbbdc7d2c029c4318ab3645a4025b5e21d11015ec76b21f5b069d49a37bd74dcad6e1f SHA512 37946af836c2d8b521618688ffee4b33c1864751081c1f1cd86442e6eb6cf822cfd9dbc228f834fbd31ca63b1dd24927cdb680076e2bd7ead941558ac1d2e436
diff --git a/dev-python/jsonpatch/jsonpatch-1.21.ebuild b/dev-python/jsonpatch/jsonpatch-1.21.ebuild
new file mode 100644
index 000000000000..3bf2670e142d
--- /dev/null
+++ b/dev-python/jsonpatch/jsonpatch-1.21.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="Apply JSON-Patches like http://tools.ietf.org/html/draft-pbryan-json-patch-04"
+HOMEPAGE="https://github.com/stefankoegl/python-json-patch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=">=dev-python/jsonpointer-1.9[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ "${PYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"
+ "${PYTHON}" ext_tests.py || die "Tests of ext_tests.py fail with ${EPYTHON}"
+}