summaryrefslogtreecommitdiff
path: root/dev-python/jsonpatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
commit6d691ad5b6239929063441bbd14c489e92e7396e (patch)
treee294f87b1ce66397fee1273bd6c7131aeb586f51 /dev-python/jsonpatch
parentd99093fb4bb5652015c06274d64083daa2439e4f (diff)
gentoo resync : 05.03.2021
Diffstat (limited to 'dev-python/jsonpatch')
-rw-r--r--dev-python/jsonpatch/Manifest2
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.31.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/jsonpatch/Manifest b/dev-python/jsonpatch/Manifest
index b03284282ba7..508af710122e 100644
--- a/dev-python/jsonpatch/Manifest
+++ b/dev-python/jsonpatch/Manifest
@@ -1,5 +1,7 @@
DIST jsonpatch-1.28.tar.gz 26829 BLAKE2B 1dee89500be23c49e5d7fdcaacb05da7ea089b691e133c5187c9558d378ae3714ad7fc6f164d0b7eea7b3cf1afefa39b7748a4637b0456051fab086e0e8f15d0 SHA512 2884cb95307cb607c8cd80e688491b4449f953e43e5b232d4d57d7249c590652ecae0856806ade6bf2807a04180e992fd2cdf61590ac058d573d653382bf7a28
DIST jsonpatch-1.30.tar.gz 27787 BLAKE2B f3294e3382baac604c31c12a790b0836732a66fdf3b6cbfbab58fcee4558140dc84a408af94f2f5861aaa17fcff49ac254f42364e5d0ba1039af0a2fd518da93 SHA512 190507eb6d6b4a81e7e804690672863d5070c140a47090b70df36d8180644618395ffc179dabf6ba24e44268b74f670abdfd260c54dc3251b12ef4b7ad17d093
+DIST jsonpatch-1.31.tar.gz 27910 BLAKE2B dbcadbe3b3937b8a543cbf871516ee047937c1a53897c535c93ee01ab301970048f4f584d1f4e96b5780c95c64a94263ee55f52efd5ba0d0c0147680ee8f9ef7 SHA512 9f08014f311d18b97f0f0cfcc931f2615e0ba5079ff5994e9ba674e079be715c3c8de3ce1c1958235b34dcbe87dee09b103295655880273ce91652d2191704c0
EBUILD jsonpatch-1.28.ebuild 841 BLAKE2B eda03acc39dba59f02ad14ba31a9817a94791a1b986cbbaf918d88a7bfe466e2585138a0f21cdef26631fcfc2637d463e4d1bb030c7c2d9812fd55e6d4efb24b SHA512 300e06017daab02ba62ef66b386ff2d3a6ccb0f7a9566c8d094e82b6d2a752ff8a015a59f9d8a5be84bd03bc0d8677bf8123e79be9a6e7d2210810c931629cf1
EBUILD jsonpatch-1.30.ebuild 845 BLAKE2B 8db3277e58f34cfd2f0129682f94ee3ecb6162063f93826316b5509d2fe13399821dd83238a24cfdc6b7bc4c35265197d01c676b60303a0e31ac42fa6d2d696f SHA512 cf9d4f52259a7af8f09a837102a0291329c4ef6d7872593f8993a174f0161db1a8af8a18a3d2f88cd446e81ad1250df3758e44bb1b6f99da23cbe57425c2145c
+EBUILD jsonpatch-1.31.ebuild 845 BLAKE2B 8db3277e58f34cfd2f0129682f94ee3ecb6162063f93826316b5509d2fe13399821dd83238a24cfdc6b7bc4c35265197d01c676b60303a0e31ac42fa6d2d696f SHA512 cf9d4f52259a7af8f09a837102a0291329c4ef6d7872593f8993a174f0161db1a8af8a18a3d2f88cd446e81ad1250df3758e44bb1b6f99da23cbe57425c2145c
MISC metadata.xml 704 BLAKE2B 774410010ca5fff3237e4864e88e19fc80bf705a166d2d278763a047cc37d2b7cef314e3c96185a42a97d32693ccd27403b990ee59acc2c30be6a8cb22ecae48 SHA512 2e2dcc4a81bae9412ffa008ed17010d1a06505a9f6be59a3c45dbc0e6b9f25f627f25f3c7ec64753e39e10e56c62ad0bb2b28c648e677ce14179678793f036e8
diff --git a/dev-python/jsonpatch/jsonpatch-1.31.ebuild b/dev-python/jsonpatch/jsonpatch-1.31.ebuild
new file mode 100644
index 000000000000..9b885b42ed8d
--- /dev/null
+++ b/dev-python/jsonpatch/jsonpatch-1.31.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Apply JSON-Patches like http://tools.ietf.org/html/draft-pbryan-json-patch-04"
+HOMEPAGE="https://github.com/stefankoegl/python-json-patch"
+SRC_URI="https://github.com/stefankoegl/python-json-patch/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/python-json-patch-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/jsonpointer-1.9[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${RDEPEND} )
+"
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"
+ "${EPYTHON}" ext_tests.py || die "Tests of ext_tests.py fail with ${EPYTHON}"
+}