summaryrefslogtreecommitdiff
path: root/dev-python/jsonpatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/jsonpatch
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/jsonpatch')
-rw-r--r--dev-python/jsonpatch/Manifest2
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.28.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/jsonpatch/Manifest b/dev-python/jsonpatch/Manifest
index ed2ce3dc8721..41510e7e0ca3 100644
--- a/dev-python/jsonpatch/Manifest
+++ b/dev-python/jsonpatch/Manifest
@@ -1,5 +1,7 @@
DIST jsonpatch-1.26.tar.gz 24440 BLAKE2B 345831bd9a9fc1902d0959685ed2dbbc0bf04d191bbc78567d27283e9ae52f7e22f50e9f400461300d1c3388712afa51d4d6a2ddd0a06dbc0a1b576b02bfe807 SHA512 1ab25c8e091cd0b772062a8c448fee4772081d8bd715489b2f7a76e4c0bdff8b26dd38b26c3037cf9bdf8780b97e62a20b6a5bdc43f43af16fdae51d1291bf52
DIST jsonpatch-1.27.tar.gz 26599 BLAKE2B b3481b4dd01d4fc6c2ad129141fb2b72d53d04744da54c1e4c989b2869113c15862d1ec5c84390758ad495ac36a9156f0e7b730ad091f96f6cb42fe96dde7fcd SHA512 297ca02d114e6b199bd516f69dca147fbe309f0a1b031046859271720645322607236f97b489c242575f7e1ad3cab0c68b1b7f11894c5af82be24013e376c0a4
+DIST jsonpatch-1.28.tar.gz 26829 BLAKE2B 1dee89500be23c49e5d7fdcaacb05da7ea089b691e133c5187c9558d378ae3714ad7fc6f164d0b7eea7b3cf1afefa39b7748a4637b0456051fab086e0e8f15d0 SHA512 2884cb95307cb607c8cd80e688491b4449f953e43e5b232d4d57d7249c590652ecae0856806ade6bf2807a04180e992fd2cdf61590ac058d573d653382bf7a28
EBUILD jsonpatch-1.26.ebuild 841 BLAKE2B 5568878443867eeb529b3c513dfb9d31c924588ada8af0f5430e9fb25b6b3253ce69e82d81695fa98ab0bb7caaf99e9df1246520d34ee9f7c294974f64df349a SHA512 780d8d1a2e30a13df1c792a4b2cea0f970e8d3ab26e8692f8a2d1a0fcc8bd484472c10346b7d61c7cb3dec825615dee5cc478bd68e0fcbea9d7f5de90e0f58f7
EBUILD jsonpatch-1.27.ebuild 845 BLAKE2B 10f66c19b9c2bf4c0bd578a05d1489fef2f1cc9d6e3d4d79cc9cc6106697026a842e5c6f0c2cbc98f398415763c135bfcbf5ad6d05bde0c7eb7a20f89a0013b9 SHA512 1bd8aa5beee9ed0da82d288c8c28d1a9700299825dae5160eed09b05b6f48eda41cc6382391d993152df62b40fe072742c80e198253f5f360aff30d846c281bd
+EBUILD jsonpatch-1.28.ebuild 845 BLAKE2B 10f66c19b9c2bf4c0bd578a05d1489fef2f1cc9d6e3d4d79cc9cc6106697026a842e5c6f0c2cbc98f398415763c135bfcbf5ad6d05bde0c7eb7a20f89a0013b9 SHA512 1bd8aa5beee9ed0da82d288c8c28d1a9700299825dae5160eed09b05b6f48eda41cc6382391d993152df62b40fe072742c80e198253f5f360aff30d846c281bd
MISC metadata.xml 704 BLAKE2B 774410010ca5fff3237e4864e88e19fc80bf705a166d2d278763a047cc37d2b7cef314e3c96185a42a97d32693ccd27403b990ee59acc2c30be6a8cb22ecae48 SHA512 2e2dcc4a81bae9412ffa008ed17010d1a06505a9f6be59a3c45dbc0e6b9f25f627f25f3c7ec64753e39e10e56c62ad0bb2b28c648e677ce14179678793f036e8
diff --git a/dev-python/jsonpatch/jsonpatch-1.28.ebuild b/dev-python/jsonpatch/jsonpatch-1.28.ebuild
new file mode 100644
index 000000000000..7b86861b301e
--- /dev/null
+++ b/dev-python/jsonpatch/jsonpatch-1.28.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Apply JSON-Patches like http://tools.ietf.org/html/draft-pbryan-json-patch-04"
+HOMEPAGE="https://github.com/stefankoegl/python-json-patch"
+SRC_URI="https://github.com/stefankoegl/python-json-patch/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/python-json-patch-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/jsonpointer-1.9[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${RDEPEND} )
+"
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"
+ "${EPYTHON}" ext_tests.py || die "Tests of ext_tests.py fail with ${EPYTHON}"
+}