summaryrefslogtreecommitdiff
path: root/dev-python/jsondiff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/jsondiff
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/jsondiff')
-rw-r--r--dev-python/jsondiff/Manifest2
-rw-r--r--dev-python/jsondiff/jsondiff-1.2.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/jsondiff/Manifest b/dev-python/jsondiff/Manifest
index 91b7db300028..273eb5b1856a 100644
--- a/dev-python/jsondiff/Manifest
+++ b/dev-python/jsondiff/Manifest
@@ -1,3 +1,5 @@
DIST jsondiff-1.1.2.tar.gz 7803 BLAKE2B cbfcfdb2c6c3bb721b4db43aca1d66649257db2cd9feb9655015e621fcd90c72af087696b9553a10ac89cdaf5f23d8748463e1a13bdb19207e34e12e66629544 SHA512 ca96bb80a6f7a34c8c5bcde74856dc1c4935b3e2979330ecfc33432aff83968e671b2aaf310c77f2c7d431be1ae6e20a960879700ba3c903a09a48b23d4c0288
+DIST jsondiff-1.2.0.tar.gz 15076 BLAKE2B 2d659598e6c647c8ea6622fc982808381e570c6ced23b5e77431b52e9fa746a5dbc743c739506362497d1f45dd2c290f23f459713ef31e927c05816e56659762 SHA512 5aa391ccc42d07330dfcf272b78aeb130f6f9033ca8b00cbea93549e32f07b98ea84cd6a1e61ab331da3de92838c69a501f95a9adb5f48e2eec46eb653264d55
EBUILD jsondiff-1.1.2.ebuild 836 BLAKE2B 4f6fbd241419838ac7fe9060bbb12599773409954b69b9d2c7720684638fdc01c4505301ac73eedbfcedbbc81c840b761c29c3f26c4906699e45729a36d0f580 SHA512 9342596313ffe7ad344460438a740402239c167e8b021eed6a80ab035a37ea4910da1ecc56e5f8f206349b3c08ebb1e07260cdb20636fcf6461a595658b1446f
+EBUILD jsondiff-1.2.0.ebuild 762 BLAKE2B bf333f1820ea0d60156ffc6e243a48c04a2428676f16c01210c3d6b087a2d1583c6bf8a08d18a316ccc14c655091b9f5a72d773aefd33588f7ce975bdc71767d SHA512 84d34aeebb50154de3f66faafb743023f38642d44b7809340665873daf7ecc8c024026b564095c39304d93e600066c01f2fd7858ff368c67b367018bb7b505c1
MISC metadata.xml 435 BLAKE2B 3ea5af8e9063a07c6d3d93225a712395a351a368bf689e512b45e6225e23a543771839e756ee53cf51142b6309f0b1ecd20fff6203a69ae754c44893d09c5274 SHA512 d1b50f01a0a5f2381fe41e4da073fd00afd4443a76d692c7a2227e50b178e9b990c4c40b72d1beeeab7cc8e5f1a9a52beb758a5adbd088eb787b9f2d08844eff
diff --git a/dev-python/jsondiff/jsondiff-1.2.0.ebuild b/dev-python/jsondiff/jsondiff-1.2.0.ebuild
new file mode 100644
index 000000000000..29227333f395
--- /dev/null
+++ b/dev-python/jsondiff/jsondiff-1.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Diff JSON and JSON-like structures in Python"
+HOMEPAGE="https://github.com/xlwings/jsondiff https://pypi.org/project/jsondiff/"
+SRC_URI="https://github.com/fzumstein/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/nose-random[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # Avoid file collision with jsonpatch's jsondiff cli.
+ sed -e "/'jsondiff=jsondiff.cli/ d" -i setup.py || die
+ distutils-r1_python_prepare_all
+}