summaryrefslogtreecommitdiff
path: root/dev-python/json5
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/json5
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/json5')
-rw-r--r--dev-python/json5/Manifest4
-rw-r--r--dev-python/json5/json5-0.9.7.ebuild27
-rw-r--r--dev-python/json5/json5-0.9.8.ebuild27
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/json5/Manifest b/dev-python/json5/Manifest
index 7cfffeaf9229..3a2b3ba43579 100644
--- a/dev-python/json5/Manifest
+++ b/dev-python/json5/Manifest
@@ -1,3 +1,7 @@
DIST json5-0.9.6.tar.gz 109927 BLAKE2B 91e01250a6a4bb3f2f8baa6a425b0721fac3888366c36de7aeed3f82123a48d91b06a1fb7458ef93f99a9bbf9f6b81e7d665a64f52652c495df99bb7af0d5cfd SHA512 6e1d8bc602ab7a13e4b495dc27df438b55f7474284af3a828f3fcae51f4b595e5a7d3be9693cdea4930721e2205db966392ba154d7b80ba7b9b6c9a7c0e7f7af
+DIST pyjson5-0.9.7.gh.tar.gz 110326 BLAKE2B 5d6da6654db8b902b211119d20be56dd3d8171100af3924c9dfe03f3bbae3581f0253e18985cf6ad8742d5b3454862ae39c56dee23bf7c1e849851755d71410e SHA512 625d1954105fdb358dafe4d1216201485ae47d3fb3c75c5a7b896899ecd5c59d92f675ff3d3349a7dc69d1dafa395b10d4a7c71f9dbd43d962965e03e5e799ac
+DIST pyjson5-0.9.8.gh.tar.gz 110629 BLAKE2B 7a2acfbf1228e8f143a19775750e6d020376d63b2b036eac75be032b7baed1e6b93ea3ee842b0c200db6f44dc0f16f3c6c2f18cb165b24918334a48f237f2a9f SHA512 e1fb7a7457bdc68c33e2d73ddae8913aeec6f001e25a70234f7233d8d28b8eee8dd023c76e26dec0d0a2051e8e2cd731044dbe7dc15af9ec95f0ce806fabac72
EBUILD json5-0.9.6.ebuild 473 BLAKE2B 1fca0455414137b16316d50699a0aa008647958d3967a953da016da6ba6995425878a66ec068af666af63c848f2136b8ddbd32e0431175657f984c3142f5bdef SHA512 2cdce64582dc9068a6dcaac3469b3ea6e849f9beb9bc3dd2f8aa2595d5d61b915251ef703154258937311a42f071fb250327529b54fbd4c414673e18af796eef
+EBUILD json5-0.9.7.ebuild 571 BLAKE2B d8dd460f3cb35524875f0d02fc237e93c15822bd73bae14a10d0d5ecc115a20a84efdd87f9bd90c2fe024abc1b88f26beba45cabac28f905ea6b9dcab7da8395 SHA512 1083e706617c29d8e7be7ee6141ae45ec5b96ef9226f171d88fb127518e4c95720339f1c38ed3e44a98ebfe584fa733d58f95e7c435b3af60f4450efb865616d
+EBUILD json5-0.9.8.ebuild 571 BLAKE2B d8dd460f3cb35524875f0d02fc237e93c15822bd73bae14a10d0d5ecc115a20a84efdd87f9bd90c2fe024abc1b88f26beba45cabac28f905ea6b9dcab7da8395 SHA512 1083e706617c29d8e7be7ee6141ae45ec5b96ef9226f171d88fb127518e4c95720339f1c38ed3e44a98ebfe584fa733d58f95e7c435b3af60f4450efb865616d
MISC metadata.xml 401 BLAKE2B f649166d283a90747bfde8907b3abc906d090f0725e7fa61cbb6bac78806dd1286da7a3ef52e9c39077a36681ee5eacbaed5d9ff9697c9d50f1c71dc9f23a2a0 SHA512 3b72503d00856242480bf81cb568ee0c9908a741f33e53ed202f8e39fb08f567fb977fb4e8df484ec9592a661326183bd51d27f3c1e5d42ba029ed7573f3caec
diff --git a/dev-python/json5/json5-0.9.7.ebuild b/dev-python/json5/json5-0.9.7.ebuild
new file mode 100644
index 000000000000..f32c70f5016e
--- /dev/null
+++ b/dev-python/json5/json5-0.9.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=pyjson5-${PV}
+DESCRIPTION="A Python implementation of the JSON5 data format"
+HOMEPAGE="
+ https://github.com/dpranke/pyjson5/
+ https://pypi.org/project/json5/
+"
+SRC_URI="
+ https://github.com/dpranke/pyjson5/archive/refs/tags/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
diff --git a/dev-python/json5/json5-0.9.8.ebuild b/dev-python/json5/json5-0.9.8.ebuild
new file mode 100644
index 000000000000..f32c70f5016e
--- /dev/null
+++ b/dev-python/json5/json5-0.9.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=pyjson5-${PV}
+DESCRIPTION="A Python implementation of the JSON5 data format"
+HOMEPAGE="
+ https://github.com/dpranke/pyjson5/
+ https://pypi.org/project/json5/
+"
+SRC_URI="
+ https://github.com/dpranke/pyjson5/archive/refs/tags/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest