summaryrefslogtreecommitdiff
path: root/dev-python/json-rpc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/json-rpc
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/json-rpc')
-rw-r--r--dev-python/json-rpc/Manifest5
-rw-r--r--dev-python/json-rpc/json-rpc-1.10.1.ebuild38
-rw-r--r--dev-python/json-rpc/metadata.xml19
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/json-rpc/Manifest b/dev-python/json-rpc/Manifest
new file mode 100644
index 000000000000..aaa4469f4642
--- /dev/null
+++ b/dev-python/json-rpc/Manifest
@@ -0,0 +1,5 @@
+DIST json-rpc-1.10.1.tar.gz 25410 SHA256 3edffc0905a08090edb4036f8767a08826ec618f9f02717251fd2eb3e1c6983b SHA512 bb69cbb12c0a64286fb1e98db21ca75cb19daf20c6d6f5721f82891a17e44d2cda172e73bd389a02077d094b8f6deb0959952b0498b0c1b4a0acfaa5e3ba3922 WHIRLPOOL c08c465be4951055a12979de5bca056cf56e35c874f491ba4891125e9fbfcc985f85d120c2a5fcb1d8b8264487af90efb34e0316981ccf546190421df5fdc885
+EBUILD json-rpc-1.10.1.ebuild 809 SHA256 76728c7461f02b12b2dc6684d473ed6a4daca71c7386239cefeb358c4f8584bd SHA512 9ce22bc24d9211288274e21aea3a987b333215cf25db80626e77a626fa86a8fac06a76857edfcd8e060df306702c7ccce4af3b7402ca384163ee21adbf8e92d7 WHIRLPOOL 1b452e76fc93b326c0e25b7fe947fb34239fae13d0ce821302dd1a522144a50381d3be157d35ba6d30fbaba5d8b025850031a45296edd538d64100995743e3cf
+MISC ChangeLog 3653 SHA256 1fb8757e287a973f39ad207c984c8382d5051b5a19e1a915400bf15bb0efe5b5 SHA512 0547733cb176221e0153656b7b8ee743611f9cd601ee239370f8cefe827e2da3ab8e2b2c8082e1087c353fa46b2090ef084310f14ecfaa07c3dfae159cee8b0a WHIRLPOOL da6cf15f9e2c600eb44ff6ce843ff7a62bd058b0523d235b66bd7863b8e62bc3eaa627a34b91e44ea0423d8ca275fc90bb8f05e2b22eea962c681f0a97be449a
+MISC ChangeLog-2015 1210 SHA256 e4d79517b2402cbfea67dd34402e383819d0dfce60e9d7b215e7e89526f957ec SHA512 70059d47c0f31160d10718650b9b01b7b25c8ce6b638799f0685f316738dff11bc9b2255843c483d1c377afdcc16edd35de1de55f170065ac697bf4a604e819b WHIRLPOOL e356ad710bbb9ee8b626cc474e39ce53a7e72e5d8a0dd0549fc263726e23fa1f9959d7f141db83cdf57da4131971c35e3dd22095f75e7f100cef87780f1dfbf9
+MISC metadata.xml 794 SHA256 b5e857cefff4992d5c565b86ef17c0b59123ea4a8eaf311da39f933b6d152af2 SHA512 68c309e9fcd29a2182d6eba1e9e758971edc2293cd3c044852de9c938ae0bdbe6ea8805b32e76656d809d6ab3d636a274cd2e65dfd21ce3f026bde5e9ae02266 WHIRLPOOL 8a8c43576c7e3685eb867e62e17926fec9649af8f37eb20b600b9cc4de154f576e19b6d474c833e24d861de0474fa245319a4a924946037d1fbd14bf9570eeb4
diff --git a/dev-python/json-rpc/json-rpc-1.10.1.ebuild b/dev-python/json-rpc/json-rpc-1.10.1.ebuild
new file mode 100644
index 000000000000..857752944190
--- /dev/null
+++ b/dev-python/json-rpc/json-rpc-1.10.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSON-RPC transport implementation for python"
+HOMEPAGE="https://github.com/pavlov99/json-rpc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ cat > jsonrpc/six.py <<- EOF
+ from __future__ import absolute_import
+ from six import *
+ EOF
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/json-rpc/metadata.xml b/dev-python/json-rpc/metadata.xml
new file mode 100644
index 000000000000..300f5e2ad4bd
--- /dev/null
+++ b/dev-python/json-rpc/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ JSON-RPC is a stateless, light-weight remote procedure call (RPC) protocol.
+ Primarily this specification defines several data structures and the rules
+ around their processing. It is transport agnostic in that the concepts can
+ be used within the same process, over sockets, over http, or in many various
+ message passing environments. It uses JSON (RFC 4627) as data format.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">json-rpc</remote-id>
+ <remote-id type="github">pavlov99/json-rpc</remote-id>
+ </upstream>
+</pkgmetadata>