summaryrefslogtreecommitdiff
path: root/dev-python/json-rpc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /dev-python/json-rpc
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'dev-python/json-rpc')
-rw-r--r--dev-python/json-rpc/Manifest4
-rw-r--r--dev-python/json-rpc/json-rpc-1.10.1.ebuild38
-rw-r--r--dev-python/json-rpc/json-rpc-1.11.0.ebuild6
3 files changed, 4 insertions, 44 deletions
diff --git a/dev-python/json-rpc/Manifest b/dev-python/json-rpc/Manifest
index bd47a7a79858..d699a0dacb9e 100644
--- a/dev-python/json-rpc/Manifest
+++ b/dev-python/json-rpc/Manifest
@@ -1,5 +1,3 @@
-DIST json-rpc-1.10.1.tar.gz 25410 BLAKE2B bb543dc9987d7aa4880d1981fad888ae9374f51958a2b7934e2779fc835705c03946cb3378ca60a914a130ae78741cda75da40ee8ce76e6b4af17a2e98498089 SHA512 bb69cbb12c0a64286fb1e98db21ca75cb19daf20c6d6f5721f82891a17e44d2cda172e73bd389a02077d094b8f6deb0959952b0498b0c1b4a0acfaa5e3ba3922
DIST json-rpc-1.11.0.tar.gz 29442 BLAKE2B b2a77bdcc2f5efe64527feb29b28c0add90b9fdbd5aa73dce18c33e9a10342c1e6b04ed5d53c110e3f1b6287cf1fdca9db77e38a04651e0a522b76c0351ec993 SHA512 aa5a467ef0e6e556612f77855d38f0dfb76b22556490fac5f0989d27b7608aed8389042ded1a0d8fcbee1f20294c78a6af3c030f41c4e30ec1effae8e51530fb
-EBUILD json-rpc-1.10.1.ebuild 809 BLAKE2B 42983942abd2fc960871292c0f87553ebb53d0f0ca34ab25b55d6bc32e66770f8767d06efb75b64ae8f9d2ff730daedf05fd7fc98a65e309221fa90811ec5f42 SHA512 9ce22bc24d9211288274e21aea3a987b333215cf25db80626e77a626fa86a8fac06a76857edfcd8e060df306702c7ccce4af3b7402ca384163ee21adbf8e92d7
-EBUILD json-rpc-1.11.0.ebuild 813 BLAKE2B fd3d5df067dfffc5401706de01c93ae07706b4cc2f63feeee67221075dbb9a0dad723594cfcccfb40b1bac9991b31a230bf590329f1e77015ed5d9b3d91d7acb SHA512 3da898d9eaece814c5c34a258328f582970c6415351a29d9560c548013971d2014025fc685a85f5d28f9766489dc98bbac137b2c11d9d5003f2b28d3dc9e485a
+EBUILD json-rpc-1.11.0.ebuild 826 BLAKE2B b8bb04bb8721e99f00946293e5d3f29cbe1a39013fd985bcc6a88af7124b8d5822eca92261d7d154a779275f6b535af9dd820d39e01826094ded3556cdd2677f SHA512 39713ec4b398c5486d834f26c22b40e08fcba3b9c6c84744810038b2069e421c7f9cab0e28dc1050a9d64d10db505596860379140a1f0053f4058626fcf39aa8
MISC metadata.xml 794 BLAKE2B c3611b6095ddf17e030c993775e3fb0b9a7c2c7ac22f5486151f2b9ad03f73bf6b0f6e467cd6440e4a6b726f4cef597cc48dd35d8973c4be941f2615b9c2b208 SHA512 68c309e9fcd29a2182d6eba1e9e758971edc2293cd3c044852de9c938ae0bdbe6ea8805b32e76656d809d6ab3d636a274cd2e65dfd21ce3f026bde5e9ae02266
diff --git a/dev-python/json-rpc/json-rpc-1.10.1.ebuild b/dev-python/json-rpc/json-rpc-1.10.1.ebuild
deleted file mode 100644
index 857752944190..000000000000
--- a/dev-python/json-rpc/json-rpc-1.10.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="JSON-RPC transport implementation for python"
-HOMEPAGE="https://github.com/pavlov99/json-rpc"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="test"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- cat > jsonrpc/six.py <<- EOF
- from __future__ import absolute_import
- from six import *
- EOF
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/json-rpc/json-rpc-1.11.0.ebuild b/dev-python/json-rpc/json-rpc-1.11.0.ebuild
index b46a3f9f107e..f37d9497f40a 100644
--- a/dev-python/json-rpc/json-rpc-1.11.0.ebuild
+++ b/dev-python/json-rpc/json-rpc-1.11.0.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
IUSE="test"
RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
@@ -28,7 +28,7 @@ DEPEND="
)"
python_prepare_all() {
- cat > jsonrpc/six.py <<- EOF
+ cat > jsonrpc/six.py <<- EOF || die
from __future__ import absolute_import
from six import *
EOF
@@ -36,5 +36,5 @@ python_prepare_all() {
}
python_test() {
- esetup.py test
+ esetup.py test || die
}