summaryrefslogtreecommitdiff
path: root/dev-python/js2py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/js2py
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/js2py')
-rw-r--r--dev-python/js2py/Manifest3
-rw-r--r--dev-python/js2py/js2py-0.70_p20210218.ebuild47
-rw-r--r--dev-python/js2py/metadata.xml16
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/js2py/Manifest b/dev-python/js2py/Manifest
new file mode 100644
index 000000000000..69d17e06718e
--- /dev/null
+++ b/dev-python/js2py/Manifest
@@ -0,0 +1,3 @@
+DIST Js2Py-0.70_p20210218.tar.gz 1969615 BLAKE2B 4702b2e771bfd2a5158a3539c33932335816c74f9dbd132679036aa2b7e53796764dd852e92d72a35ecc31efa34b849776c45d8c81e80f85f59308edf0996f00 SHA512 757c895bc0ba933020336a70473ec4455cb93c17040a39f17d645782011ea72273291448f3448ffd34658b48ada45b77facf3d326133f1c0d63e2e26e2cd7f30
+EBUILD js2py-0.70_p20210218.ebuild 1104 BLAKE2B 7468b86817d2cc6eac70d19d84a28667520ac46b075e1967dffedcf8042fdde7f5974174816977aaca8ebcac026a2fe363414f61e618670ac72ac55b5a8b57de SHA512 13c446847663b6b574f74d0b6ed7873c4f28a2bdefb944a12354e05c6c9cf2e19d86c0db302378adc9f4464f30ff544cffeb6a5a85526c855f0d50b28d319f84
+MISC metadata.xml 546 BLAKE2B 725ee93573250bef3db5d8bdc1bc4cbb6c8af06a8f1a395564843de779151a447d28e56ccc64456659d72c066b1341a8215f8f259f1861d53d5aaa921e25d751 SHA512 40a016ead490a75d46c2eb031911d5869870da7adeaee05231d3f38602cb290936a5986b2cd8f22f68489acfb0b288aa12e383f8dce2f225a7d223e9c9b52a4d
diff --git a/dev-python/js2py/js2py-0.70_p20210218.ebuild b/dev-python/js2py/js2py-0.70_p20210218.ebuild
new file mode 100644
index 000000000000..ee455c5dfa5b
--- /dev/null
+++ b/dev-python/js2py/js2py-0.70_p20210218.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_COMMIT="ea16b519a0f72e17416859a57890b8388fce6e39"
+
+MY_PN="Js2Py"
+MY_P="${MY_PN}-${PV}"
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="JavaScript to Python Translator & JavaScript interpreter in Python"
+HOMEPAGE="
+ http://piter.io/projects/js2py/
+ https://github.com/PiotrDabkowski/Js2Py/
+ https://pypi.org/project/Js2Py/
+"
+SRC_URI="https://github.com/PiotrDabkowski/${MY_PN}/archive/${MY_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pyjsparser-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/tzlocal-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_PN}-${MY_COMMIT}"
+
+python_test() {
+ pushd ./tests >/dev/null || die
+
+ # Tests require "node_failed.txt" file where the logs are kept
+ if [[ -f ./node_failed.txt ]]; then
+ rm ./node_failed.txt || die
+ fi
+
+ touch ./node_failed.txt || die
+ "${EPYTHON}" ./run.py || die "tests failed with ${EPYTHON}"
+
+ popd >/dev/null || die
+}
diff --git a/dev-python/js2py/metadata.xml b/dev-python/js2py/metadata.xml
new file mode 100644
index 000000000000..03e41f2cd8e4
--- /dev/null
+++ b/dev-python/js2py/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@protonmail.com</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">PiotrDabkowski/Js2Py</remote-id>
+ <remote-id type="pypi">Js2Py</remote-id>
+ </upstream>
+</pkgmetadata>